ramips: add new device ZyXEL Keenetic as kn
[openwrt/openwrt.git] / target / linux / ramips / image / rt305x.mk
index 69533ce9e78f802020f5ee9d530ca6a3576f2284..62ced9b7dea0aa82060568a582b48c2b05065140 100644 (file)
@@ -850,3 +850,12 @@ define Device/xdxrn502j
   DEVICE_TITLE := XDX RN502J
 endef
 TARGET_DEVICES += xdxrn502j
+
+define Device/kn
+  DTS := kn
+  BLOCKSIZE := 64k
+  IMAGE_SIZE := $(ralink_default_fw_size_4M)
+  DEVICE_TITLE := ZyXEL Keenetic
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += kn