ramips: add usb-ledtrig-usbport to DEVICE_PACKAGES of CY-SWR1100
[openwrt/openwrt.git] / target / linux / ramips / image / rt3883.mk
index abee533d01019410de6bd662b5b75e9413fd6357..8219967f441392964ced6cdcf6c62cc945bd94c8 100644 (file)
@@ -24,7 +24,8 @@ define Device/cy-swr1100
   KERNEL := $(KERNEL_DTB)
   SEAMA_SIGNATURE := wrgnd10_samsung_ss815
   DEVICE_TITLE := Samsung CY-SWR1100
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 | \
+       kmod-usb-ledtrig-usbport swconfig
 endef
 TARGET_DEVICES += cy-swr1100
 
@@ -41,6 +42,18 @@ endef
 TARGET_DEVICES += dir-645
 
 
+define Device/belkin_f9k1109v1
+  DTS := F9K1109V1
+  BLOCKSIZE := 64k
+  DEVICE_TITLE := Belkin F9K1109 Version 1.0
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
+  IMAGE_SIZE := 7224k
+  KERNEL := kernel-bin | patch-dtb | lzma -d16 | uImage lzma
+  # Stock firmware checks for this uImage image name during upload.
+  UIMAGE_NAME := N750F9K1103VB
+endef
+TARGET_DEVICES += belkin_f9k1109v1
+
 define Device/hpm
   DTS := HPM
   BLOCKSIZE := 64k