x86: Add board configs for the PC Engines APU2
[openwrt/openwrt.git] / target / linux / x86 / generic / target.mk
index 765d7085090c418d7d95c3e9fc6d59a403931738..90586f56d6a730908964849fdc89e43d28e58861 100644 (file)
@@ -1,9 +1,11 @@
 BOARDNAME:=Generic
-
-LINUX_VERSION:=3.8.10
+CPU_TYPE :=pentium4
+FEATURES += audio pci pcie usb
+DEFAULT_PACKAGES += kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for x86 based boards
-       (e.g : Soekris, ...)
+       Build firmware images for modern x86 based boards with CPUs
+       supporting at least the Intel Pentium 4 instruction set with
+       MMX, SSE and SSE2.
 endef