bison: replace the yacc script with one that does not hardcode the path (fixes #20605)
[openwrt/openwrt.git] / tools / bison / Makefile
index 3909ec3313e655bdb943ea876a692391e632f134..256512116f9f7b8f90f2dcce24846286e5c50025 100644 (file)
@@ -7,22 +7,25 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bison
-PKG_VERSION:=3.0
+PKG_VERSION:=3.0.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
-PKG_MD5SUM:=a2624994561aa69f056c904c1ccb2880
+PKG_MD5SUM:=146be9ff9fbd27497f0bf2286a5a2082
 PKG_CAT:=xzcat
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 PKG_CAT:=xzcat
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-HOST_LDFLAGS += $(HOST_STATIC_LINKING)
-
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
 endef
 
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
 endef
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(INSTALL_BIN) ./scripts/yacc $(STAGING_DIR_HOST)/bin/yacc
+endef
+
 $(eval $(call HostBuild))
 $(eval $(call HostBuild))