cmake: properly pass host cflags/ldflags to the build
[openwrt/openwrt.git] / tools / cmake / Makefile
index c56cd40fb5a92b5240cacd0138b89d51ff6f65c6..f3712391a6acf1127ceaffa4590b86f77a3a54dd 100644 (file)
@@ -24,9 +24,14 @@ HOST_CONFIGURE_CMD := \
        $(BASH) ./configure \
                $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
 
-HOST_CONFIGURE_VARS :=
+HOST_CONFIGURE_VARS += \
+       CXXFLAGS="$(HOST_CFLAGS)"
 
 HOST_CONFIGURE_ARGS := \
        --prefix=$(STAGING_DIR_HOST)
 
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+  HOST_MAKE_FLAGS += VERBOSE=1
+endif
+
 $(eval $(call HostBuild))