cmake: properly pass host cflags/ldflags to the build
authorFelix Fietkau <nbd@nbd.name>
Thu, 12 Jan 2017 13:41:01 +0000 (14:41 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 09:23:43 +0000 (10:23 +0100)
This should hopefully fix build issues where libraries that we ship in
tools/ were accidentally picked up from other places on the system, e.g.
/usr/local

Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/cmake/Makefile

index 08e5a69ecfcf4b26b88f98b7715f8f0ac5706388..f3712391a6acf1127ceaffa4590b86f77a3a54dd 100644 (file)
@@ -24,7 +24,8 @@ HOST_CONFIGURE_CMD := \
        $(BASH) ./configure \
                $(if $(MAKE_JOBSERVER),--parallel="$(MAKE_JOBSERVER)")
 
-HOST_CONFIGURE_VARS :=
+HOST_CONFIGURE_VARS += \
+       CXXFLAGS="$(HOST_CFLAGS)"
 
 HOST_CONFIGURE_ARGS := \
        --prefix=$(STAGING_DIR_HOST)