tools/cmake: Update to 3.11.0
[openwrt/openwrt.git] / tools / cmake / patches / 100-disable_qt_tests.patch
index 6f28c435e018f53fedc3ba840298b6aaf8a07e9b..46cdc945638b357ab009efa92d71ee19aa80be1a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Tests/RunCMake/CMakeLists.txt
 +++ b/Tests/RunCMake/CMakeLists.txt
-@@ -225,15 +225,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -284,15 +284,6 @@ add_RunCMake_test(no_install_prefix)
  add_RunCMake_test(configure_file)
  add_RunCMake_test(CTestTimeoutAfterMatch)
  
    add_RunCMake_test(FindPkgConfig)
 --- a/Tests/CMakeLists.txt
 +++ b/Tests/CMakeLists.txt
-@@ -393,10 +393,6 @@ if(BUILD_TESTING)
+@@ -422,13 +422,6 @@ if(BUILD_TESTING)
  
    list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
  
--  if(NOT QT4_FOUND)
+-  if(NOT DEFINED CMake_TEST_Qt4)
+-    set(CMake_TEST_Qt4 1)
+-  endif()
+-  if(CMake_TEST_Qt4 AND NOT QT4_FOUND)
 -    find_package(Qt4 QUIET)
 -  endif()
 -
-   if(QT4_FOUND)
+   if(CMake_TEST_Qt4 AND QT4_FOUND)
      # test whether the Qt4 which has been found works, on some machines
      # which run nightly builds there were errors like "wrong file format"