tools/cmake: Update to 3.11.0
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Wed, 4 Apr 2018 08:02:32 +0000 (10:02 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Wed, 11 Apr 2018 19:02:29 +0000 (21:02 +0200)
Update cmake to 3.11.0
Remove 110-alpine_musl-compat.patch as it's integrated upstream
Rename and refresh patches

Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
tools/cmake/Makefile
tools/cmake/patches/100-disable_qt_tests.patch
tools/cmake/patches/110-alpine_musl-compat.patch [deleted file]
tools/cmake/patches/110-libarchive-fix-libressl-compat.patch [new file with mode: 0644]
tools/cmake/patches/120-curl-fix-libressl-linking.patch [new file with mode: 0644]
tools/cmake/patches/120-libarchive-fix-libressl-compat.patch [deleted file]
tools/cmake/patches/130-bootstrap_parallel_make_flag.patch [new file with mode: 0644]
tools/cmake/patches/130-curl-fix-libressl-linking.patch [deleted file]
tools/cmake/patches/140-bootstrap_parallel_make_flag.patch [deleted file]

index f11b92061103e92f1eb899259f5bf5d9c2939b5c..8211c8d44b188728ff3b338e63f65f8951275537 100644 (file)
@@ -7,13 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=3.10.1
+PKG_VERSION:=3.11.0
 PKG_CPE_ID:=cpe:/a:kitware:cmake
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.10/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.11/ \
                https://fossies.org/linux/misc/
-PKG_HASH:=7be36ee24b0f5928251b644d29f5ff268330a916944ef4a75e23ba01e7573284
+PKG_HASH:=c313bee371d4d255be2b4e96fd59b11d58bc550a7c78c021444ae565709a656b
 
 HOST_BUILD_PARALLEL:=1
 HOST_CONFIGURE_PARALLEL:=1
index 6e8307dea4dca10a575e6f572defb3755300dfcb..46cdc945638b357ab009efa92d71ee19aa80be1a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Tests/RunCMake/CMakeLists.txt
 +++ b/Tests/RunCMake/CMakeLists.txt
-@@ -273,15 +273,6 @@ add_RunCMake_test(no_install_prefix)
+@@ -284,15 +284,6 @@ add_RunCMake_test(no_install_prefix)
  add_RunCMake_test(configure_file)
  add_RunCMake_test(CTestTimeoutAfterMatch)
  
@@ -18,7 +18,7 @@
    add_RunCMake_test(FindPkgConfig)
 --- a/Tests/CMakeLists.txt
 +++ b/Tests/CMakeLists.txt
-@@ -407,13 +407,6 @@ if(BUILD_TESTING)
+@@ -422,13 +422,6 @@ if(BUILD_TESTING)
  
    list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
  
diff --git a/tools/cmake/patches/110-alpine_musl-compat.patch b/tools/cmake/patches/110-alpine_musl-compat.patch
deleted file mode 100644 (file)
index a2c84fc..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Utilities/cmjsoncpp/include/json/assertions.h
-+++ b/Utilities/cmjsoncpp/include/json/assertions.h
-@@ -6,11 +6,12 @@
- #ifndef CPPTL_JSON_ASSERTIONS_H_INCLUDED
- #define CPPTL_JSON_ASSERTIONS_H_INCLUDED
-+#include <stdlib.h>
-+
- #if !defined(JSON_IS_AMALGAMATION)
- #include "config.h"
- #endif // if !defined(JSON_IS_AMALGAMATION)
--#include <stdlib.h>
- #include <sstream>
- /** It should not be possible for a maliciously designed file to
diff --git a/tools/cmake/patches/110-libarchive-fix-libressl-compat.patch b/tools/cmake/patches/110-libarchive-fix-libressl-compat.patch
new file mode 100644 (file)
index 0000000..ba6565b
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Utilities/cmlibarchive/libarchive/archive_openssl_evp_private.h
++++ b/Utilities/cmlibarchive/libarchive/archive_openssl_evp_private.h
+@@ -28,7 +28,7 @@
+ #include <openssl/evp.h>
+ #include <openssl/opensslv.h>
+-#if OPENSSL_VERSION_NUMBER < 0x10100000L
++#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
+ #include <stdlib.h> /* malloc, free */
+ #include <string.h> /* memset */
+ static inline EVP_MD_CTX *EVP_MD_CTX_new(void)
diff --git a/tools/cmake/patches/120-curl-fix-libressl-linking.patch b/tools/cmake/patches/120-curl-fix-libressl-linking.patch
new file mode 100644 (file)
index 0000000..ad5b897
--- /dev/null
@@ -0,0 +1,33 @@
+From: Jo-Philipp Wich <jo@mein.io>
+Date: Wed, 11 Jan 2017 03:36:04 +0100
+Subject: [PATCH] cmcurl: link librt
+
+When cmake is linked against LibreSSL, there might be an indirect
+dependency on librt on certain systems if LibreSSL's libcrypto uses
+clock_gettime() from librt:
+
+    [ 28%] Linking C executable LIBCURL
+    .../lib/libcrypto.a(getentropy_linux.o): In function `getentropy_fallback':
+    getentropy_linux.c:(.text+0x16d): undefined reference to `clock_gettime'
+    getentropy_linux.c:(.text+0x412): undefined reference to `clock_gettime'
+    collect2: error: ld returned 1 exit status
+    make[5]: *** [Utilities/cmcurl/LIBCURL] Error 1
+
+Modify the cmcurl CMakeLists.txt to check for clock_gettime() in librt
+and unconditionally link the rt library when the symbol is found.
+
+Signed-off-by: Jo-Philipp Wich <jo@mein.io>
+---
+--- a/Utilities/cmcurl/CMakeLists.txt
++++ b/Utilities/cmcurl/CMakeLists.txt
+@@ -461,6 +461,10 @@ if(CMAKE_USE_OPENSSL)
+   set(USE_OPENSSL ON)
+   set(HAVE_LIBCRYPTO ON)
+   set(HAVE_LIBSSL ON)
++  check_library_exists("rt" clock_gettime "" HAVE_LIBRT)
++  if(HAVE_LIBRT)
++    list(APPEND OPENSSL_LIBRARIES rt)
++  endif()
+   list(APPEND CURL_LIBS ${OPENSSL_LIBRARIES})
+   include_directories(${OPENSSL_INCLUDE_DIR})
+   set(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})
diff --git a/tools/cmake/patches/120-libarchive-fix-libressl-compat.patch b/tools/cmake/patches/120-libarchive-fix-libressl-compat.patch
deleted file mode 100644 (file)
index ba6565b..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/Utilities/cmlibarchive/libarchive/archive_openssl_evp_private.h
-+++ b/Utilities/cmlibarchive/libarchive/archive_openssl_evp_private.h
-@@ -28,7 +28,7 @@
- #include <openssl/evp.h>
- #include <openssl/opensslv.h>
--#if OPENSSL_VERSION_NUMBER < 0x10100000L
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
- #include <stdlib.h> /* malloc, free */
- #include <string.h> /* memset */
- static inline EVP_MD_CTX *EVP_MD_CTX_new(void)
diff --git a/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/130-bootstrap_parallel_make_flag.patch
new file mode 100644 (file)
index 0000000..de5137e
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/bootstrap
++++ b/bootstrap
+@@ -1149,7 +1149,10 @@ int main(){ printf("1%c", (char)0x0a); r
+ ' > "test.c"
+ cmake_original_make_flags="${cmake_make_flags}"
+ if [ "x${cmake_parallel_make}" != "x" ]; then
+-  cmake_make_flags="${cmake_make_flags} -j ${cmake_parallel_make}"
++  case "$cmake_paralle_make" in
++    [0-9]*) cmake_parallel_make="-j ${cmake_parallel_make}";;
++  esac
++  cmake_make_flags="${cmake_make_flags} ${cmake_parallel_make}"
+ fi
+ for a in ${cmake_make_processors}; do
+   if [ -z "${cmake_make_processor}" ] && cmake_try_make "${a}" "${cmake_make_flags}" >> ../cmake_bootstrap.log 2>&1; then
diff --git a/tools/cmake/patches/130-curl-fix-libressl-linking.patch b/tools/cmake/patches/130-curl-fix-libressl-linking.patch
deleted file mode 100644 (file)
index ad5b897..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From: Jo-Philipp Wich <jo@mein.io>
-Date: Wed, 11 Jan 2017 03:36:04 +0100
-Subject: [PATCH] cmcurl: link librt
-
-When cmake is linked against LibreSSL, there might be an indirect
-dependency on librt on certain systems if LibreSSL's libcrypto uses
-clock_gettime() from librt:
-
-    [ 28%] Linking C executable LIBCURL
-    .../lib/libcrypto.a(getentropy_linux.o): In function `getentropy_fallback':
-    getentropy_linux.c:(.text+0x16d): undefined reference to `clock_gettime'
-    getentropy_linux.c:(.text+0x412): undefined reference to `clock_gettime'
-    collect2: error: ld returned 1 exit status
-    make[5]: *** [Utilities/cmcurl/LIBCURL] Error 1
-
-Modify the cmcurl CMakeLists.txt to check for clock_gettime() in librt
-and unconditionally link the rt library when the symbol is found.
-
-Signed-off-by: Jo-Philipp Wich <jo@mein.io>
----
---- a/Utilities/cmcurl/CMakeLists.txt
-+++ b/Utilities/cmcurl/CMakeLists.txt
-@@ -461,6 +461,10 @@ if(CMAKE_USE_OPENSSL)
-   set(USE_OPENSSL ON)
-   set(HAVE_LIBCRYPTO ON)
-   set(HAVE_LIBSSL ON)
-+  check_library_exists("rt" clock_gettime "" HAVE_LIBRT)
-+  if(HAVE_LIBRT)
-+    list(APPEND OPENSSL_LIBRARIES rt)
-+  endif()
-   list(APPEND CURL_LIBS ${OPENSSL_LIBRARIES})
-   include_directories(${OPENSSL_INCLUDE_DIR})
-   set(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})
diff --git a/tools/cmake/patches/140-bootstrap_parallel_make_flag.patch b/tools/cmake/patches/140-bootstrap_parallel_make_flag.patch
deleted file mode 100644 (file)
index a3cdefb..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/bootstrap
-+++ b/bootstrap
-@@ -1130,7 +1130,10 @@ int main(){ printf("1%c", (char)0x0a); r
- ' > "test.c"
- cmake_original_make_flags="${cmake_make_flags}"
- if [ "x${cmake_parallel_make}" != "x" ]; then
--  cmake_make_flags="${cmake_make_flags} -j ${cmake_parallel_make}"
-+  case "$cmake_paralle_make" in
-+    [0-9]*) cmake_parallel_make="-j ${cmake_parallel_make}";;
-+  esac
-+  cmake_make_flags="${cmake_make_flags} ${cmake_parallel_make}"
- fi
- for a in ${cmake_make_processors}; do
-   if [ -z "${cmake_make_processor}" ] && cmake_try_make "${a}" "${cmake_make_flags}" >> ../cmake_bootstrap.log 2>&1; then