tools/sparse: Update to snapshot 2017-03-31
[openwrt/openwrt.git] / tools / gmp / Makefile
index 5028ae0627619fe33f2b114535637a358e40513c..19dc8215f3f8a6b55fb83a7f6317d534a4de746a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gmp
-PKG_VERSION:=5.1.1
+PKG_VERSION:=6.1.2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gmp/
-PKG_MD5SUM:=485b1296e6287fa381e6015b19767989
+PKG_HASH:=87b565e89a9a684fe4ebeeddb8399dce2599f9c9049854ca8c0dfbdea0e21912
 
 HOST_FIXUP:=autoreconf
 
@@ -24,7 +24,12 @@ unexport CFLAGS
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --disable-assembly \
        --enable-cxx \
        --enable-mpbsd
 
+ifeq ($(GNU_HOST_NAME),x86_64-linux-gnux32)
+HOST_CONFIGURE_ARGS += ABI=x32
+endif
+
 $(eval $(call HostBuild))