kernel: Added required dependencies for socket match.
[openwrt/openwrt.git] / tools / mpfr / Makefile
index 47ff1c55398caaec17f31591d735da1e575f5095..fdb316efb961984f5f92aa9439e8827a1929f2f9 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=3.1.5
+PKG_VERSION:=4.0.2
+PKG_CPE_ID:=cpe:/a:mpfr:gnu_mpfr
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION) \
-               @GNU/mpfr
+PKG_SOURCE_URL:=@GNU/mpfr http://www.mpfr.org/mpfr-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_MD5SUM:=c4ac246cf9795a4491e7766002cd528f
+PKG_HASH:=1d3be708604eae0e42d578ba93b390c2a145f17743a744d8f3f8c2ad5855a38a
 
 HOST_BUILD_PARALLEL:=1
 HOST_FIXUP:=autoreconf
@@ -22,6 +22,7 @@ include $(INCLUDE_DIR)/host-build.mk
 HOST_CONFIGURE_ARGS += \
        --enable-static \
        --disable-shared \
+       --enable-thread-safe \
        --with-gmp=$(STAGING_DIR_HOST)
 
 $(eval $(call HostBuild))