fconfig: cleanup Makefile
authorMichael Heimpold <mhei@heimpold.de>
Tue, 26 Mar 2019 21:09:24 +0000 (22:09 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 6 Apr 2019 17:14:06 +0000 (19:14 +0200)
We do not need to define an empty Build/Configure since
the default checks for existing ./configure and does nothing
in case nothing is found.

Similar for Build/Compile: we can remove the definition
when we only call the default.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
package/boot/fconfig/Makefile

index d82fa8db9002f5073c0ab4777f343319fb9327e2..9b806fe97cd0ff5de92b3192d0b1df1d31281789 100644 (file)
@@ -30,13 +30,6 @@ define Package/fconfig/description
        displays and (if writable) also edits the RedBoot configuration.
 endef
 
        displays and (if writable) also edits the RedBoot configuration.
 endef
 
-define Build/Configure
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default)
-endef
-
 define Package/fconfig/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fconfig $(1)/usr/sbin/
 define Package/fconfig/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/fconfig $(1)/usr/sbin/