mac80211: fix kconfig recursive dependency warning
authorFelix Fietkau <nbd@nbd.name>
Tue, 18 Apr 2017 07:42:04 +0000 (09:42 +0200)
committerFelix Fietkau <nbd@nbd.name>
Tue, 18 Apr 2017 07:45:18 +0000 (09:45 +0200)
Make brcmfmac depend on !TARGET_uml.
Technically, brcmfmac could be built for uml because only SDIO support
won't work on that target. However, selectively avoiding the dependency
propagation of !TARGET_uml from kmod-mmc to avoid including a reference
to BRCMFMAC_SDIO doesn't work.

In practice, brcmfmac is completely useless on uml, so let's just
disable it there.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mac80211/Makefile

index c5a2577d6ecefe76865677238ed152dcfe653964..39cda128555268ceb3611a2be04af13375187ee4 100644 (file)
@@ -689,7 +689,7 @@ define KernelPackage/brcmfmac
   TITLE:=Broadcom IEEE802.11n USB FullMAC WLAN driver
   URL:=https://wireless.wiki.kernel.org/en/users/drivers/brcm80211
   DEPENDS+= @USB_SUPPORT +kmod-cfg80211 +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT +kmod-brcmutil \
-       +BRCMFMAC_SDIO&&!TARGET_uml:kmod-mmc \
+       +BRCMFMAC_SDIO:kmod-mmc @!TARGET_uml \
        +BRCMFMAC_USB:kmod-usb-core +BRCMFMAC_USB:brcmfmac-firmware-usb
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko
   AUTOLOAD:=$(call AutoProbe,brcmfmac)
@@ -704,7 +704,6 @@ define KernelPackage/brcmfmac/config
 
        config BRCMFMAC_SDIO
                bool "Enable SDIO bus interface support"
-               depends on !TARGET_uml
                default y if TARGET_brcm2708
                default n
                help