add palantir
authorNicolas Thill <nico@openwrt.org>
Tue, 20 Sep 2005 00:15:07 +0000 (00:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 20 Sep 2005 00:15:07 +0000 (00:15 +0000)
SVN-Revision: 1956

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/palantir/Config.in [new file with mode: 0644]
openwrt/package/palantir/Makefile [new file with mode: 0644]
openwrt/package/palantir/ipkg/palantir.conffiles [new file with mode: 0644]
openwrt/package/palantir/ipkg/palantir.control [new file with mode: 0644]

index 3a7af6cce92d5188d667df0c3d2ab6536624e2aa..344bda8541549e90aaabb8a97ee607372e12fab7 100644 (file)
@@ -178,6 +178,7 @@ comment "Multimedia ---"
 source "package/gmediaserver/Config.in"
 source "package/mt-daapd/Config.in"
 source "package/mpd/Config.in"
+source "package/palantir/Config.in"
 source "package/setpwc/Config.in"
 
 comment "Serial communications & terminal emulation ---"
index 0ecc0402dc0ce46490de32b7da6ca45cb35f9fe3..dcb695f496e416869329ca562ae675477f70020c 100644 (file)
@@ -121,6 +121,7 @@ package-$(BR2_PACKAGE_OPENSSL) += openssl
 package-$(BR2_PACKAGE_OPENSWAN) += openswan
 package-$(BR2_PACKAGE_OPENVPN) += openvpn
 package-$(BR2_PACKAGE_OSIRIS) += osiris
+package-$(BR2_PACKAGE_PALANTIR) += palantir
 package-$(BR2_PACKAGE_PARPROUTED) += parprouted
 package-$(BR2_PACKAGE_PCRE) += pcre
 package-$(BR2_COMPILE_PHP4) += php4
@@ -238,6 +239,7 @@ openssh-compile: zlib-compile openssl-compile
 openssl-compile: zlib-compile
 openswan-compile: gmp-compile
 osiris-compile: openssl-compile
+palantir-compile: jpeg-compile
 portmap-compile: tcp_wrappers-compile
 postgresql-compile: zlib-compile
 ppp-compile: linux-atm-compile
diff --git a/openwrt/package/palantir/Config.in b/openwrt/package/palantir/Config.in
new file mode 100644 (file)
index 0000000..c08437f
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_PALANTIR
+       tristate "palantir - a multichannel interactive streaming solution"
+       default m if CONFIG_DEVEL
+       select LIBJPEG
+       help
+         Palantir is a Linux-based streaming system designed to transmit live 
+         video, audio and data over a TCP/IP network, as well as to control 
+         remote devices.
+         
+         http://www.fastpath.it/products/palantir/
+         
diff --git a/openwrt/package/palantir/Makefile b/openwrt/package/palantir/Makefile
new file mode 100644 (file)
index 0000000..68eac5f
--- /dev/null
@@ -0,0 +1,46 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=palantir
+PKG_VERSION:=2.6
+PKG_RELEASE:=1
+PKG_MD5SUM:=8e4d20e7f7fad26d7447483c68894ace
+
+PKG_SOURCE_URL:=http://www.fastpath.it/products/palantir/pub/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+export CPPFLAGS=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+export LDFLAGS=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,PALANTIR,palantir,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       touch $@
+
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)/usr
+       $(MAKE) -C $(PKG_BUILD_DIR)/server/libgsm \
+               $(TARGET_CONFIGURE_OPTS) \
+               CCINC="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               lib/libgsm.a
+       $(MAKE) -C $(PKG_BUILD_DIR)/server \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="-Wall -D_REENTRANT $(TARGET_CFLAGS)" \
+               palantir
+       touch $@
+
+$(IPKG_PALANTIR):
+       install -d -m0755 $(IDIR_PALANTIR)/etc
+       install -m0644 $(PKG_BUILD_DIR)/server/palantir-mips.conf.sample $(IDIR_PALANTIR)/etc/palantir.conf
+       install -d -m0755 $(IDIR_PALANTIR)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/server/palantir $(IDIR_PALANTIR)/usr/sbin/
+       $(RSTRIP) $(IDIR_PALANTIR)
+       $(IPKG_BUILD) $(IDIR_PALANTIR) $(PACKAGE_DIR)
diff --git a/openwrt/package/palantir/ipkg/palantir.conffiles b/openwrt/package/palantir/ipkg/palantir.conffiles
new file mode 100644 (file)
index 0000000..a57f0c6
--- /dev/null
@@ -0,0 +1 @@
+/etc/palantir.conf
diff --git a/openwrt/package/palantir/ipkg/palantir.control b/openwrt/package/palantir/ipkg/palantir.control
new file mode 100644 (file)
index 0000000..2d87537
--- /dev/null
@@ -0,0 +1,7 @@
+Package: palantir
+Priority: optional
+Section: net
+Maintainer: OpenWrt Developer Team <openwrt-devel@openwrt.org>
+Source:  http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/palantir/
+Depends: libjpeg, libpthread
+Description: A multichannel interactive streaming solution