busybox: drop providing virtual package ip
authorHans Dedecker <dedeckeh@gmail.com>
Thu, 22 Mar 2018 20:43:04 +0000 (21:43 +0100)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 22 Mar 2018 20:54:20 +0000 (21:54 +0100)
Drop providing the virtual package ip by busybox which was added in commit
1cec4d4ef0.

Letting busybox provide the virtual package ip is not optimal for the
following reasons :

- Applications depending on ip expect either the ip-full or
  ip-tiny package to be enabled.
- Busybox ip applet cannot be added or removed at runtime

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/utils/busybox/Makefile

index 4f85cc9614dcddcb6f30cc4f662921ff56cdfd7c..623fbd5896f98ab0c4f0118b6e41d4eaae5f8e1a 100644 (file)
@@ -46,7 +46,6 @@ define Package/busybox
   URL:=http://busybox.net/
   DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam +BUSYBOX_CONFIG_NTPD:jsonfilter
   MENU:=1
-  PROVIDES:=ip
   ALTERNATIVES:=\
     $(call BUSYBOX_IF_ENABLED,KILL,    100:/bin/kill:/bin/busybox) \
     $(call BUSYBOX_IF_ENABLED,PS,      100:/bin/ps:/bin/busybox) \