sunxi: add support for Orange Pi Zero
authorJulian Haupt <julian.haupt@hauptmedia.de>
Sun, 30 Sep 2018 14:42:03 +0000 (14:42 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 7 Oct 2018 20:16:10 +0000 (22:16 +0200)
Signed-off-by: Julian Haupt <julian.haupt@hauptmedia.de>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a7.mk

index b3d9c1eb69a700a3a63fdb7f9b96eae002c367bc..1728cc2f1ea9cb221fca83f97439d354bff60c45 100644 (file)
@@ -150,6 +150,12 @@ define U-Boot/orangepi_r1
   BUILD_DEVICES:=sun8i-h2-plus-orangepi-r1
 endef
 
+define U-Boot/orangepi_zero
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=Orange Pi Zero (H2+)
+  BUILD_DEVICES:=sun8i-h2-plus-orangepi-zero
+endef
+
 define U-Boot/orangepi_pc
   BUILD_SUBTARGET:=cortexa7
   NAME:=Orange Pi PC (H3)
@@ -246,6 +252,7 @@ UBOOT_TARGETS := \
        nanopi_neo \
        nanopi_neo_plus2 \
        nanopi_neo2 \
+       orangepi_zero \
        orangepi_r1 \
        orangepi_pc \
        orangepi_plus \
index 986b6395c4bd21c7c2519e09867b374a2803c2a1..5d6046543b39a64df26709d8c6b5a76ef4dc55b8 100644 (file)
@@ -108,6 +108,16 @@ endef
 TARGET_DEVICES += sun6i-a31-m9
 
 
+define Device/sun8i-h2-plus-orangepi-zero
+  DEVICE_TITLE:=Xunlong Orange Pi Zero
+  DEVICE_PACKAGES:=kmod-rtc-sunxi
+  SUPPORTED_DEVICES:=xunlong,orangepi-zero
+  SUNXI_DTS:=sun8i-h2-plus-orangepi-zero
+endef
+
+TARGET_DEVICES += sun8i-h2-plus-orangepi-zero
+
+
 define Device/sun8i-h2-plus-orangepi-r1
   DEVICE_TITLE:=Xunlong Orange Pi R1
   DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152