ramips: make the relocation address configurable
authorSungbo Eo <mans0n@gorani.run>
Sat, 29 Jan 2022 14:24:07 +0000 (23:24 +0900)
committerSungbo Eo <mans0n@gorani.run>
Sat, 29 Jan 2022 14:50:28 +0000 (23:50 +0900)
If no argument is given to relocate-kernel, KERNEL_LOADADDR will be used
just as before.

This is a preparation for ramips support of ipTIME AX2004M.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ramips/image/Makefile

index ac256cf1ae0e88140a8b834e11152362ada9ece8..241b6209411c3f43aca057c1ad27e87edbc5f2d0 100644 (file)
@@ -113,7 +113,7 @@ endef
 define Build/relocate-kernel
        rm -rf $@.relocate
        $(CP) ../../generic/image/relocate $@.relocate
-       $(MAKE) -C $@.relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
+       $(MAKE) -C $@.relocate KERNEL_ADDR=$(if $(1),$(1),$(KERNEL_LOADADDR)) CROSS_COMPILE=$(TARGET_CROSS)
        ( \
                dd if=$@.relocate/loader.bin bs=32 conv=sync && \
                perl -e '@s = stat("$@"); print pack("V", @s[7])' && \