utils/mdadm: fix build on hosts without /run dir
authorSergey V. Lobanov <sergey@lobanov.in>
Sun, 2 Jan 2022 19:18:04 +0000 (22:18 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 7 Jan 2022 23:49:59 +0000 (00:49 +0100)
CHECK_RUN_DIR=0 must be a part of MAKE_FLAGS, not MAKE_VARS, otherwise
it is not possible to compile mdadm on host without /run dir.

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
package/utils/mdadm/Makefile

index f20a58b7046c480df4b49c9b6dc246d06928c028..f6696bf21cb38b6b16cf5d1eb404a02c44c3a087 100644 (file)
@@ -52,7 +52,7 @@ TARGET_CFLAGS += \
 
 TARGET_LDFLAGS += -Wl,--gc-sections
 
-MAKE_VARS += CHECK_RUN_DIR=0
+MAKE_FLAGS += CHECK_RUN_DIR=0
 
 define Build/Compile
        $(call Build/Compile/Default,mdadm)