hostapd: remove erroneous $(space) redefinition
authorJo-Philipp Wich <jo@mein.io>
Sat, 8 Feb 2020 10:34:41 +0000 (11:34 +0100)
committerJo-Philipp Wich <jo@mein.io>
Sat, 8 Feb 2020 10:54:23 +0000 (11:54 +0100)
The $(space) definition in the hostapd Makefile ceased to work with
GNU Make 4.3 and later, leading to syntax errors in the generated
Kconfig files.

Drop the superfluous redefinition and reuse the working $(space)
declaration from rules.mk to fix this issue.

Fixes: GH#2713
Ref: https://github.com/openwrt/openwrt/pull/2713#issuecomment-583722469
Reported-by: Karel Kočí <cynerd@email.cz>
Suggested-by: Jonas Gorski <jonas.gorski@gmail.com>
Tested-by: Shaleen Jain <shaleen@jain.sh>
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
(backported from commit 766e778226f5d4c6ec49ce22b101a5dbd4306644)

package/network/services/hostapd/Makefile

index 9712e7247aaecbed9f79eb666974954f85291a0a..9d9f4d451c6cef24f076b415896aed2fd0da36c1 100644 (file)
@@ -88,9 +88,6 @@ DRIVER_MAKEOPTS= \
        CONFIG_IEEE80211AC=$(HOSTAPD_IEEE80211AC) \
        CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
 
-space :=
-space +=
-
 ifeq ($(LOCAL_VARIANT),full)
   DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
 endif