openssl: add --gc-sections
authorDirk Feytons <dirk.feytons@gmail.com>
Thu, 2 Jun 2016 11:43:14 +0000 (13:43 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sat, 23 Jul 2016 10:10:08 +0000 (12:10 +0200)
Signed-off-by: Dirk Feytons <dirk.feytons@gmail.com>
package/libs/openssl/Makefile

index 8e439e1c31b69a76ba9963294ebbb4d9f5628e1e..393976598b992a49ea9aac8f9f58144fffd25d85 100644 (file)
@@ -184,7 +184,8 @@ define Build/Configure
                depend
 endef
 
-TARGET_CFLAGS += $(FPIC) -I$(CURDIR)/include
+TARGET_CFLAGS += $(FPIC) -I$(CURDIR)/include -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \