ramips: mt76x8: add support for TP-Link RE365 v1
authorTomasz Maciej Nowak <tmn505@gmail.com>
Wed, 10 Jan 2024 15:39:57 +0000 (16:39 +0100)
committerSander Vanheule <sander@svanheule.net>
Wed, 10 Jan 2024 19:56:06 +0000 (20:56 +0100)
TP-Link RE365 is a wireless range extender, hardware-wise resembles
RE305 with slight changes regarding buttons and LEDs.

Specification
SoC: MediaTek MT7628AN
RAM: 64 MiB DDR2
Flash: 8 MiB SPI NOR
WiFi: 2.4 GHz 2T2R integrated
      5 GHz 2T2R MediaTek MT7612EN conncted to PCIe lanes
Ethernet: 1x 10/100 Mbps integrated
LEDs: 6x GPIO controlled
Buttons: 4x GPIO controlled
UART: row of 4 holes marked on PCB as J1, starting count from white
      triangle
      1. VCC (3.3V), 2. GND, 3. RX, 4. TX
      baud: 57600, parity: none, flow control: none

Installation
1. Open web management interface.
2. Go to Settings > System Tools > Firmware upgrade.
3. Select "Browse" and select the OpenWrt image with factory.bin suffix.
4. After selecting "Upgrade" firmware writing process will start.
5. Wait till device reboots, power LED should stay solid when it's fully
   booted, then it's ready for configuration through LAN port.

Additional information
With how device manufacturer patrtitioned the flash memory, it's possible
that with default packages set, initial factory.bin image won't be
created. In such case, try to reduce packages amount or use older release
for initial conversion to OpenWrt. Later You can use sysupgrade.bin
image with full set of packages because OpenWrt uses unpartitioned flash
memory space unused by vendor firmware.

Reverting to vendor firmware involves converting firmware using
tplink-safeloader with -z option (can be found in ImageBuilder or SDK)
and forcibly applying converted firmware as sysupgrade.

Known issues
WARNING: after removing casing of the device one is exposed to high
voltage and is in a risk of being electrocuted.

Caution when interfacing whith bootloader, saving its environment either
by issuing "saveenv" or selecting option "1: Load system code to SDRAM
via TFTP." in boot menu, any of those will lead to overwriting part of
kernel. This will lead to need of firmware recovery. The cause of this
issue is bootloader having environment offset on flash at 0x40000,
while kernel starts from 0x20000.

Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
[Wrap long line in DTS]
Signed-off-by: Sander Vanheule <sander@svanheule.net>
target/linux/ramips/dts/mt7628an_tplink_re365-v1.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt76x8/base-files/etc/board.d/01_leds
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7628an_tplink_re365-v1.dts b/target/linux/ramips/dts/mt7628an_tplink_re365-v1.dts
new file mode 100644 (file)
index 0000000..17fa9c0
--- /dev/null
@@ -0,0 +1,214 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/leds/common.h>
+
+/ {
+       model = "TP-Link RE365 v1";
+       compatible = "tplink,re365-v1", "mediatek,mt7628an-soc";
+
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+               label-mac-device = &ethernet;
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               button-led {
+                       label = "led";
+                       gpios = <&gpio 44 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_LIGHTS_TOGGLE>;
+               };
+
+               button-power {
+                       label = "power";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_POWER>;
+               };
+
+               button-reset {
+                       label = "reset";
+                       gpios = <&gpio 37 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               button-wps {
+                       label = "wps";
+                       gpios = <&gpio 38 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_WPS_BUTTON>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led-lan {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_LAN;
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+
+               led_power: led-power {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_POWER;
+                       gpios = <&gpio 39 GPIO_ACTIVE_LOW>;
+                       panic-indicator;
+               };
+
+               led-rssi-bad {
+                       color = <LED_COLOR_ID_RED>;
+                       function = LED_FUNCTION_INDICATOR;
+                       gpios = <&gpio 43 GPIO_ACTIVE_HIGH>;
+               };
+
+               led-rssi-good {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_INDICATOR;
+                       gpios = <&gpio 42 GPIO_ACTIVE_HIGH>;
+               };
+
+               led-wlan2g {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_WLAN;
+                       function-enumerator = <2>;
+                       gpios = <&gpio 41 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               led-wlan5g {
+                       color = <LED_COLOR_ID_BLUE>;
+                       function = LED_FUNCTION_WLAN;
+                       function-enumerator = <5>;
+                       gpios = <&gpio 40 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+       };
+
+       virtual_flash {
+               compatible = "mtd-concat";
+               devices = <&fwconcat0>, <&fwconcat1>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               compatible = "tplink,firmware";
+                               label = "firmware";
+                               reg = <0x0 0x0>;
+                       };
+               };
+       };
+};
+
+&ethernet {
+       nvmem-cells = <&macaddr_config_10008 0>;
+       nvmem-cell-names = "mac-address";
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       mt76@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               ieee80211-freq-limit = <5000000 6000000>;
+               nvmem-cells = <&eeprom_radio_8000>, <&macaddr_config_10008 2>;
+               nvmem-cell-names = "eeprom", "mac-address";
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x20000>;
+                               read-only;
+                       };
+
+                       fwconcat0: partition@20000 {
+                               label = "fwconcat0";
+                               reg = <0x20000 0x5e0000>;
+                       };
+
+                       partition@600000 {
+                               label = "config";
+                               reg = <0x600000 0x50000>;
+                               read-only;
+
+                               nvmem-layout {
+                                       compatible = "fixed-layout";
+                                       #address-cells = <1>;
+                                       #size-cells = <1>;
+
+                                       macaddr_config_10008: macaddr@10008 {
+                                               compatible = "mac-base";
+                                               reg = <0x10008 0x6>;
+                                               #nvmem-cell-cells = <1>;
+                                       };
+                               };
+                       };
+
+                       fwconcat1: partition@650000 {
+                               label = "fwconcat1";
+                               reg = <0x650000 0x1a0000>;
+                       };
+
+                       partition@7f0000 {
+                               label = "radio";
+                               reg = <0x7f0000 0x10000>;
+                               read-only;
+
+                               nvmem-layout {
+                                       compatible = "fixed-layout";
+                                       #address-cells = <1>;
+                                       #size-cells = <1>;
+
+                                       eeprom_radio_0: eeprom@0 {
+                                               reg = <0x0 0x400>;
+                                       };
+
+                                       eeprom_radio_8000: eeprom@8000 {
+                                               reg = <0x8000 0x200>;
+                                       };
+                               };
+                       };
+               };
+       };
+};
+
+&state_default {
+       gpio {
+               groups = "refclk", "wdt", "p0led_an", "p1led_an", "p2led_an", "p3led_an",
+                       "p4led_an";
+               function = "gpio";
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       nvmem-cells = <&eeprom_radio_0>, <&macaddr_config_10008 1>;
+       nvmem-cell-names = "eeprom", "mac-address";
+};
index 8a6bccfba63b6b7972c459dec0b1ea10f8cc749b..9a458d38f392187e3190e6e92e4180dde9ec1032 100644 (file)
@@ -666,6 +666,18 @@ define Device/tplink_re305-v3
 endef
 TARGET_DEVICES += tplink_re305-v3
 
+define Device/tplink_re365-v1
+  $(Device/tplink-safeloader)
+  DEVICE_MODEL := RE365
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES := kmod-mt76x2
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
+  IMAGE_SIZE := 7680k
+  KERNEL_SIZE := 6016k
+  TPLINK_BOARD_ID := RE365
+endef
+TARGET_DEVICES += tplink_re365-v1
+
 define Device/tplink_tl-mr3020-v3
   $(Device/tplink-v2)
   IMAGE_SIZE := 7808k
index c4301737b28b6461339acd449879949f0f912f78..5a0e0ab2148e488c17dbef75a92611f3c179ed37 100644 (file)
@@ -91,6 +91,9 @@ tplink,tl-mr3020-v3|\
 tplink,tl-wa801nd-v5)
        ucidef_set_led_netdev "lan" "lan" "green:lan" "eth0"
        ;;
+tplink,re365-v1)
+       ucidef_set_led_netdev "lan" "lan" "blue:lan" "eth0"
+       ;;
 tplink,tl-mr3420-v5|\
 tplink,tl-wr840n-v4|\
 tplink,tl-wr842n-v5)
index fe3ac9193ff9fb2039be1cf0974ffc8b7d698485..63abb14d13916dd87d4473f8486e54a55aa449f5 100644 (file)
@@ -27,6 +27,7 @@ ramips_setup_interfaces()
        tplink,re220-v2|\
        tplink,re305-v1|\
        tplink,re305-v3|\
+       tplink,re365-v1|\
        tplink,tl-wr802n-v4|\
        tplink,tl-wa801nd-v5|\
        tplink,tl-wr902ac-v4|\