ath79: improve factory.bin for some Senao devices
authorMichael Pratt <mcpratt@pm.me>
Wed, 17 Mar 2021 23:07:46 +0000 (19:07 -0400)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Mar 2022 18:54:57 +0000 (19:54 +0100)
Some boards with firmware made with Senao SDK based on Linux 3.3
have the following lines in the OEM upgrade script at
/etc/fwupgrade.sh

local append=""
local CONF_TAR="/tmp/sysupgrade.tgz"
[ -f "$CONF_TAR" ] && append="-j $CONF_TAR"

and

\# check FWINFO filename
[ -z $(ls FWINFO* | grep -i ${modelname}) ] && errcode="1"

This addition also prevents needing to factory reset after flashing
for some boards that also have these lines in the script

\# Support downgrade but do default (Smart v2.x.x.x -> senaowrt v1.x.x.x)
[ $(ls FWINFO* | grep -i ${modelname} | cut -d "-" -f4 | cut -c 2) -lt 2 ] && append=""

Signed-off-by: Michael Pratt <mcpratt@pm.me>
target/linux/ath79/image/common-senao.mk

index c9c14944c4627250184dd678ec6a20594a523487..dda7da6776e7b0afa90299b50bb3295a4cf4eaeb 100644 (file)
@@ -1,6 +1,6 @@
 DEVICE_VARS += SENAO_IMGNAME
 
-# This needs to make /tmp/_sys/sysupgrade.tgz an empty file prior to
+# This needs to make OEM config archive 'sysupgrade.tgz' an empty file prior to OEM
 # sysupgrade, as otherwise it will implant the old configuration from
 # OEM firmware when writing rootfs from factory.bin
 # rootfs size and checksum is taken from a squashfs header
@@ -9,7 +9,9 @@ define Build/senao-tar-gz
        -[ -f "$@" ] && \
        mkdir -p $@.tmp && \
        touch $@.tmp/failsafe.bin && \
+       touch $@.tmp/FWINFO-$(word 1,$(1))-$(REVISION) && \
        echo '#!/bin/sh' > $@.tmp/before-upgrade.sh && \
+       echo ': > /tmp/sysupgrade.tgz' >> $@.tmp/before-upgrade.sh && \
        echo ': > /tmp/_sys/sysupgrade.tgz' >> $@.tmp/before-upgrade.sh && \
        echo -n $$(( $$(cat $@ | wc -c) / 4096 * 4096 )) > $@.len && \
        dd if=$@ bs=$$(cat $@.len) count=1 | md5sum - | cut -d ' ' -f 1 > $@.md5 && \