mac80211: update to latest wireless-testing from today
authorFelix Fietkau <nbd@openwrt.org>
Wed, 3 Feb 2010 00:43:09 +0000 (00:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 3 Feb 2010 00:43:09 +0000 (00:43 +0000)
SVN-Revision: 19501

14 files changed:
package/mac80211/Makefile
package/mac80211/patches/403-ath9k-fix-invalid-mac-address-handling.patch
package/mac80211/patches/405-ath9k-read-eeprom-data-from-platform-data-on-pci-bus.patch
package/mac80211/patches/406-ath9k-set-AH_USE_EEPROM-only-if-no-platform-data-present.patch
package/mac80211/patches/407-ath9k-override-mac-address-from-platform-data.patch
package/mac80211/patches/408-ath9k_tweak_rx_intr_mitigation.patch
package/mac80211/patches/500-ath9k_debugfs_chainmask.patch
package/mac80211/patches/510-ath9k_debugfs_regaccess.patch
package/mac80211/patches/520-ath9k_ack_timeout_workaround.patch
package/mac80211/patches/540-ath9k_fix_eap_handling.patch [new file with mode: 0644]
package/mac80211/patches/540-rx_mgmt_handling.patch [deleted file]
package/mac80211/patches/550-radiotap_ps_buffer.patch [deleted file]
package/mac80211/patches/560-ath9k_fix_eap_handling.patch [deleted file]
package/mac80211/patches/570-ap_vlan_injection.patch [deleted file]

index 9321e4fe22820ad89016d182549563bb7763fe15..4e98a5dc0f061ca8043b267a0811213da0dea0f8 100644 (file)
@@ -10,12 +10,12 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mac80211
 
-PKG_VERSION:=2010-01-25
-PKG_RELEASE:=2
+PKG_VERSION:=2010-02-02
+PKG_RELEASE:=1
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 #      http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/11 \
 #      http://wireless.kernel.org/download/compat-wireless-2.6
-PKG_MD5SUM:=66a1d519e7ebcbadd4e47e6e56f705af
+PKG_MD5SUM:=32602171b840132cbaa62d4b67f32d2c
 
 PKG_SOURCE:=compat-wireless-$(PKG_VERSION).tar.bz2
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
index c41495175269d82a4a4346f7a182c2d5818ee641..bb3796ab013ea4875ee3ac7d8c01511b2b1b8b82 100644 (file)
@@ -8,7 +8,7 @@
  #include <asm/unaligned.h>
  
  #include "hw.h"
-@@ -437,8 +438,18 @@ static int ath9k_hw_init_macaddr(struct 
+@@ -441,8 +442,18 @@ static int ath9k_hw_init_macaddr(struct 
                common->macaddr[2 * i] = eeval >> 8;
                common->macaddr[2 * i + 1] = eeval & 0xff;
        }
index 2f33d2e20dfd7925c4dda40a7818eb5993504e3c..e9bd604472f69ba2251b663c62cfa9c521ef6171 100644 (file)
@@ -8,7 +8,7 @@
  #include "ath9k.h"
  
  static struct pci_device_id ath_pci_id_table[] __devinitdata = {
-@@ -61,21 +62,36 @@ static void ath_pci_cleanup(struct ath_c
+@@ -52,21 +53,36 @@ static void ath_pci_read_cachesize(struc
  
  static bool ath_pci_eeprom_read(struct ath_common *common, u32 off, u16 *data)
  {
index a83242f919482b94d6b4471582d0a9170d9ded2a..799c1186f8966b69ca1897c2f018cf145e8a77b5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath9k/hw.c
 +++ b/drivers/net/wireless/ath/ath9k/hw.c
-@@ -381,11 +381,8 @@ static void ath9k_hw_init_defaults(struc
+@@ -385,11 +385,8 @@ static void ath9k_hw_init_defaults(struc
        ah->hw_version.magic = AR5416_MAGIC;
        ah->hw_version.subvendorid = 0;
  
index dae663dd7ad4d183b288ab46db5c017edf46e08f..c92cd17e0b289e81c15d5cb5623bda378696257f 100644 (file)
@@ -11,7 +11,7 @@
  #include "hw.h"
  #include "rc.h"
  #include "initvals.h"
-@@ -424,17 +426,23 @@ static int ath9k_hw_rf_claim(struct ath_
+@@ -428,17 +430,23 @@ static int ath9k_hw_rf_claim(struct ath_
  static int ath9k_hw_init_macaddr(struct ath_hw *ah)
  {
        struct ath_common *common = ath9k_hw_common(ah);
index 72d638e9f420074dff51f22a46ad5f310bf9a99a..949a9a7e2d4f67eeb87914627c922c725bfe9fc6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath9k/hw.c
 +++ b/drivers/net/wireless/ath/ath9k/hw.c
-@@ -2087,7 +2087,7 @@ int ath9k_hw_reset(struct ath_hw *ah, st
+@@ -2092,7 +2092,7 @@ int ath9k_hw_reset(struct ath_hw *ah, st
  
        if (ah->config.rx_intr_mitigation) {
                REG_RMW_FIELD(ah, AR_RIMT, AR_RIMT_LAST, 500);
index 7d043d693b70292c405801fe6e36706478a0c012..eaed50091945977750660d825d4d81929843ce09 100644 (file)
@@ -1,8 +1,8 @@
 --- a/drivers/net/wireless/ath/ath9k/debug.c
 +++ b/drivers/net/wireless/ath/ath9k/debug.c
-@@ -75,6 +75,90 @@ static const struct file_operations fops
+@@ -77,6 +77,90 @@ static const struct file_operations fops
  
- #endif
+ #define DMA_BUF_LEN 1024
  
 +static ssize_t read_file_tx_chainmask(struct file *file, char __user *user_buf,
 +                           size_t count, loff_t *ppos)
@@ -91,7 +91,7 @@
  static ssize_t read_file_dma(struct file *file, char __user *user_buf,
                             size_t count, loff_t *ppos)
  {
-@@ -710,6 +794,16 @@ int ath9k_init_debug(struct ath_hw *ah)
+@@ -719,6 +803,16 @@ int ath9k_init_debug(struct ath_hw *ah)
                goto err;
  #endif
  
        sc->debug.debugfs_dma = debugfs_create_file("dma", S_IRUSR,
                                       sc->debug.debugfs_phy, sc, &fops_dma);
        if (!sc->debug.debugfs_dma)
-@@ -760,6 +854,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
+@@ -769,6 +863,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
        struct ath_common *common = ath9k_hw_common(ah);
        struct ath_softc *sc = (struct ath_softc *) common->priv;
  
index 02e4cac375a9c23e7eb09e777baffdc230b5a7eb..dda4b88e8c86f26c53c839b53dcec4f6fb4feb37 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath9k/debug.c
 +++ b/drivers/net/wireless/ath/ath9k/debug.c
-@@ -774,6 +774,86 @@ static const struct file_operations fops
+@@ -783,6 +783,86 @@ static const struct file_operations fops
        .owner = THIS_MODULE
  };
  
@@ -87,7 +87,7 @@
  int ath9k_init_debug(struct ath_hw *ah)
  {
        struct ath_common *common = ath9k_hw_common(ah);
-@@ -843,6 +923,17 @@ int ath9k_init_debug(struct ath_hw *ah)
+@@ -852,6 +932,17 @@ int ath9k_init_debug(struct ath_hw *ah)
        if (!sc->debug.debugfs_recv)
                goto err;
  
        return 0;
  err:
        ath9k_exit_debug(ah);
-@@ -856,6 +947,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
+@@ -865,6 +956,8 @@ void ath9k_exit_debug(struct ath_hw *ah)
  
        debugfs_remove(sc->debug.debugfs_tx_chainmask);
        debugfs_remove(sc->debug.debugfs_rx_chainmask);
index 7b51204a54451a82c0790a484e805d27efd1ecbc..398bec8eb80aa8dae8aa9bb4ea03590aea74a28e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/ath/ath9k/hw.c
 +++ b/drivers/net/wireless/ath/ath9k/hw.c
-@@ -1228,6 +1228,11 @@ void ath9k_hw_init_global_settings(struc
+@@ -1233,6 +1233,11 @@ void ath9k_hw_init_global_settings(struc
        /* As defined by IEEE 802.11-2007 17.3.8.6 */
        slottime = ah->slottime + 3 * ah->coverage_class;
        acktimeout = slottime + sifstime;
diff --git a/package/mac80211/patches/540-ath9k_fix_eap_handling.patch b/package/mac80211/patches/540-ath9k_fix_eap_handling.patch
new file mode 100644 (file)
index 0000000..75e5e93
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/drivers/net/wireless/ath/ath9k/xmit.c
++++ b/drivers/net/wireless/ath/ath9k/xmit.c
+@@ -1610,7 +1610,7 @@ static int ath_tx_setup_buffer(struct ie
+               bf->bf_frmlen -= padsize;
+       }
+-      if (conf_is_ht(&hw->conf) && !is_pae(skb))
++      if (conf_is_ht(&hw->conf))
+               bf->bf_state.bf_type |= BUF_HT;
+       bf->bf_flags = setup_tx_flags(sc, skb, txctl->txq);
+@@ -1696,7 +1696,7 @@ static void ath_tx_start_dma(struct ath_
+                       goto tx_done;
+               }
+-              if (tx_info->flags & IEEE80211_TX_CTL_AMPDU) {
++              if ((tx_info->flags & IEEE80211_TX_CTL_AMPDU) && !is_pae(skb)) {
+                       /*
+                        * Try aggregation if it's a unicast data frame
+                        * and the destination is HT capable.
diff --git a/package/mac80211/patches/540-rx_mgmt_handling.patch b/package/mac80211/patches/540-rx_mgmt_handling.patch
deleted file mode 100644 (file)
index 7992125..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/net/mac80211/rx.c
-+++ b/net/mac80211/rx.c
-@@ -2359,7 +2359,7 @@ static void __ieee80211_rx_handle_packet
-                               continue;
-                       }
--                      rx.sta = sta_info_get(prev, hdr->addr2);
-+                      rx.sta = sta_info_get_bss(prev, hdr->addr2);
-                       rx.flags |= IEEE80211_RX_RA_MATCH;
-                       prepares = prepare_for_handlers(prev, &rx, hdr);
-@@ -2395,7 +2395,7 @@ next:
-               }
-               if (prev) {
--                      rx.sta = sta_info_get(prev, hdr->addr2);
-+                      rx.sta = sta_info_get_bss(prev, hdr->addr2);
-                       rx.flags |= IEEE80211_RX_RA_MATCH;
-                       prepares = prepare_for_handlers(prev, &rx, hdr);
diff --git a/package/mac80211/patches/550-radiotap_ps_buffer.patch b/package/mac80211/patches/550-radiotap_ps_buffer.patch
deleted file mode 100644 (file)
index 67d8f49..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
---- a/include/net/mac80211.h
-+++ b/include/net/mac80211.h
-@@ -274,6 +274,8 @@ struct ieee80211_bss_conf {
-  * @IEEE80211_TX_INTFL_RETRANSMISSION: This frame is being retransmitted
-  *    after TX status because the destination was asleep, it must not
-  *    be modified again (no seqno assignment, crypto, etc.)
-+ * @IEEE80211_TX_INTFL_HAS_RADIOTAP: This frame was injected and still
-+ *    has a radiotap header at skb->data.
-  */
- enum mac80211_tx_control_flags {
-       IEEE80211_TX_CTL_REQ_TX_STATUS          = BIT(0),
-@@ -295,6 +297,7 @@ enum mac80211_tx_control_flags {
-       IEEE80211_TX_CTL_PSPOLL_RESPONSE        = BIT(17),
-       IEEE80211_TX_CTL_MORE_FRAMES            = BIT(18),
-       IEEE80211_TX_INTFL_RETRANSMISSION       = BIT(19),
-+      IEEE80211_TX_INTFL_HAS_RADIOTAP         = BIT(20),
- };
- /**
---- a/net/mac80211/tx.c
-+++ b/net/mac80211/tx.c
-@@ -1110,7 +1110,7 @@ ieee80211_tx_prepare(struct ieee80211_su
-       tx->flags |= IEEE80211_TX_FRAGMENTED;
-       /* process and remove the injection radiotap header */
--      if (unlikely(info->flags & IEEE80211_TX_CTL_INJECTED)) {
-+      if (unlikely(info->flags & IEEE80211_TX_INTFL_HAS_RADIOTAP)) {
-               if (!__ieee80211_parse_tx_radiotap(tx, skb))
-                       return TX_DROP;
-@@ -1119,6 +1119,7 @@ ieee80211_tx_prepare(struct ieee80211_su
-                * the radiotap header that was present and pre-filled
-                * 'tx' with tx control information.
-                */
-+              info->flags &= ~IEEE80211_TX_INTFL_HAS_RADIOTAP;
-       }
-       /*
-@@ -1501,7 +1502,8 @@ static void ieee80211_xmit(struct ieee80
-               int hdrlen;
-               u16 len_rthdr;
--              info->flags |= IEEE80211_TX_CTL_INJECTED;
-+              info->flags |= IEEE80211_TX_CTL_INJECTED |
-+                             IEEE80211_TX_INTFL_HAS_RADIOTAP;
-               len_rthdr = ieee80211_get_radiotap_len(skb->data);
-               hdr = (struct ieee80211_hdr *)(skb->data + len_rthdr);
diff --git a/package/mac80211/patches/560-ath9k_fix_eap_handling.patch b/package/mac80211/patches/560-ath9k_fix_eap_handling.patch
deleted file mode 100644 (file)
index d72fa97..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/drivers/net/wireless/ath/ath9k/xmit.c
-+++ b/drivers/net/wireless/ath/ath9k/xmit.c
-@@ -1353,25 +1353,6 @@ static enum ath9k_pkt_type get_hw_packet
-       return htype;
- }
--static bool is_pae(struct sk_buff *skb)
--{
--      struct ieee80211_hdr *hdr;
--      __le16 fc;
--
--      hdr = (struct ieee80211_hdr *)skb->data;
--      fc = hdr->frame_control;
--
--      if (ieee80211_is_data(fc)) {
--              if (ieee80211_is_nullfunc(fc) ||
--                  /* Port Access Entity (IEEE 802.1X) */
--                  (skb->protocol == cpu_to_be16(ETH_P_PAE))) {
--                      return true;
--              }
--      }
--
--      return false;
--}
--
- static int get_hw_crypto_keytype(struct sk_buff *skb)
- {
-       struct ieee80211_tx_info *tx_info = IEEE80211_SKB_CB(skb);
-@@ -1610,7 +1591,7 @@ static int ath_tx_setup_buffer(struct ie
-               bf->bf_frmlen -= padsize;
-       }
--      if (conf_is_ht(&hw->conf) && !is_pae(skb))
-+      if (conf_is_ht(&hw->conf))
-               bf->bf_state.bf_type |= BUF_HT;
-       bf->bf_flags = setup_tx_flags(sc, skb, txctl->txq);
diff --git a/package/mac80211/patches/570-ap_vlan_injection.patch b/package/mac80211/patches/570-ap_vlan_injection.patch
deleted file mode 100644 (file)
index 581b4a0..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/net/mac80211/tx.c
-+++ b/net/mac80211/tx.c
-@@ -1135,6 +1135,8 @@ ieee80211_tx_prepare(struct ieee80211_su
-               tx->sta = rcu_dereference(sdata->u.vlan.sta);
-               if (!tx->sta && sdata->dev->ieee80211_ptr->use_4addr)
-                       return TX_DROP;
-+      } else if (info->flags & IEEE80211_TX_CTL_INJECTED) {
-+              tx->sta = sta_info_get_bss(sdata, hdr->addr1);
-       }
-       if (!tx->sta)
-               tx->sta = sta_info_get(sdata, hdr->addr1);