Prior to kernel 2.6.23, architecture path was i386, allow that when switching kernel...
authorFlorian Fainelli <florian@openwrt.org>
Sat, 28 Jun 2008 11:08:01 +0000 (11:08 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 28 Jun 2008 11:08:01 +0000 (11:08 +0000)
SVN-Revision: 11594

target/linux/rdc/image/Makefile

index 4da96b7e18474f5c1940d15fb90246cc55a89734..a8ad0996683253eb12eaeeed00c5f8cc9b636868 100644 (file)
@@ -7,8 +7,14 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+ifeq ($(CONFIG_LINUX_2_6_23),y)
+ARCH_PATH=i386
+else
+ARCH_PATH=x86
+endif
+
 define Image/Prepare
-       $(CP) $(LINUX_DIR)/arch/x86/boot/bzImage $(KDIR)/bzImage
+       $(CP) $(LINUX_DIR)/arch/$(ARCH_PATH)/boot/bzImage $(KDIR)/bzImage
 endef
 
 define trxalign/jffs2-128k