add the infrastructure to use a MPI/GPIO connected VoIP DSP
authorFlorian Fainelli <florian@openwrt.org>
Wed, 1 Jul 2009 21:00:41 +0000 (21:00 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 1 Jul 2009 21:00:41 +0000 (21:00 +0000)
SVN-Revision: 16650

target/linux/brcm63xx/files/arch/mips/bcm63xx/Makefile
target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
target/linux/brcm63xx/files/arch/mips/bcm63xx/dev-dsp.c [new file with mode: 0644]
target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/bcm63xx_dev_dsp.h [new file with mode: 0644]
target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/board_bcm963xx.h

index d121274cc3422c3b50d6c57ce8f6633d83c494e7..b9343a8d6cfa193a713b23e23bf67febbc5fd533 100644 (file)
@@ -7,6 +7,7 @@ obj-y           += dev-usb-udc.o
 obj-y          += dev-enet.o
 obj-y          += dev-wdt.o
 obj-y          += dev-spi.o
 obj-y          += dev-enet.o
 obj-y          += dev-wdt.o
 obj-y          += dev-spi.o
+obj-y          += dev-dsp.o
 obj-$(CONFIG_EARLY_PRINTK)     += early_printk.o
 
 obj-y          += boards/
 obj-$(CONFIG_EARLY_PRINTK)     += early_printk.o
 
 obj-y          += boards/
index 18389983a7438548014365de660b6daf67dfc18f..b9ff9759eb8a74d6d274c4b56f6e5692b0d53596 100644 (file)
@@ -24,6 +24,7 @@
 #include <bcm63xx_dev_uart.h>
 #include <bcm63xx_dev_wdt.h>
 #include <bcm63xx_dev_enet.h>
 #include <bcm63xx_dev_uart.h>
 #include <bcm63xx_dev_wdt.h>
 #include <bcm63xx_dev_enet.h>
+#include <bcm63xx_dev_dsp.h>
 #include <bcm63xx_dev_pcmcia.h>
 #include <bcm63xx_dev_usb_ohci.h>
 #include <bcm63xx_dev_usb_ehci.h>
 #include <bcm63xx_dev_pcmcia.h>
 #include <bcm63xx_dev_usb_ohci.h>
 #include <bcm63xx_dev_usb_ehci.h>
@@ -114,6 +115,14 @@ static struct board_info __initdata board_96348gw_10 = {
        .has_ohci0                      = 1,
        .has_pccard                     = 1,
        .has_ehci0                      = 1,
        .has_ohci0                      = 1,
        .has_pccard                     = 1,
        .has_ehci0                      = 1,
+
+       .has_dsp                        = 1,
+       .dsp = {
+               .gpio_rst               = 6,
+               .gpio_int               = 34,
+               .cs                     = 2,
+               .ext_irq                = 2,
+       },
 }; 
 
 static struct board_info __initdata board_96348gw_11 = {
 }; 
 
 static struct board_info __initdata board_96348gw_11 = {
@@ -157,7 +166,15 @@ static struct board_info __initdata board_96348gw = {
                .force_duplex_full      = 1,
        },
 
                .force_duplex_full      = 1,
        },
 
-       .has_ohci0 = 1,
+       .has_ohci0                      = 1,
+       .has_dsp                        = 1,
+       
+       .dsp = {
+               .gpio_rst               = 6,
+               .gpio_int               = 34,
+               .ext_irq                = 2,
+               .cs                     = 2,
+       },
 };
 
 static struct board_info __initdata board_FAST2404 = {
 };
 
 static struct board_info __initdata board_FAST2404 = {
@@ -559,6 +576,10 @@ int __init board_register_devices(void)
 
        if (board.has_udc0)
                bcm63xx_udc_register();
 
        if (board.has_udc0)
                bcm63xx_udc_register();
+
+       if (board.has_dsp)
+               bcm63xx_dsp_register(&board.dsp);
+       
        /* Generate MAC address for WLAN and
         * register our SPROM */
 #ifdef CONFIG_PCI
        /* Generate MAC address for WLAN and
         * register our SPROM */
 #ifdef CONFIG_PCI
diff --git a/target/linux/brcm63xx/files/arch/mips/bcm63xx/dev-dsp.c b/target/linux/brcm63xx/files/arch/mips/bcm63xx/dev-dsp.c
new file mode 100644 (file)
index 0000000..08a2f75
--- /dev/null
@@ -0,0 +1,56 @@
+/*
+ * Broadcom BCM63xx VoIP DSP registration
+ *
+ * This file is subject to the terms and conditions of the GNU General Public
+ * License.  See the file "COPYING" in the main directory of this archive
+ * for more details.
+ *
+ * Copyright (C) 2009 Florian Fainelli <florian@openwrt.org> 
+ */
+
+#include <linux/init.h>
+#include <linux/kernel.h>
+#include <linux/platform_device.h>
+
+#include <bcm63xx_cpu.h>
+#include <bcm63xx_dev_dsp.h>
+#include <bcm63xx_regs.h>
+#include <bcm63xx_io.h>
+
+static struct resource voip_dsp_resources[] = {
+       {
+               .start          = -1, /* filled at runtime */
+               .end            = -1, /* filled at runtime */
+               .flags          = IORESOURCE_MEM,
+       },
+       {
+               .start          = -1, /* filled at runtime */
+               .flags          = IORESOURCE_IRQ,
+       },
+};
+
+static struct platform_device bcm63xx_voip_dsp_device = {
+       .name           = "bcm63xx-voip-dsp",
+       .id             = 0,
+       .num_resources  = ARRAY_SIZE(voip_dsp_resources),
+       .resource       = voip_dsp_resources,
+};
+
+int __init bcm63xx_dsp_register(const struct bcm63xx_dsp_platform_data *pd)
+{
+       struct bcm63xx_dsp_platform_data *dpd;
+       u32 val;
+
+       /* Get the memory window */
+       val = bcm_mpi_readl(MPI_CSBASE_REG(pd->cs - 1));
+       val &= MPI_CSBASE_BASE_MASK;
+       voip_dsp_resources[0].start = val;
+       voip_dsp_resources[0].end = val + 0xFFFFFFF;
+       voip_dsp_resources[1].start = pd->ext_irq;
+
+       /* copy given platform data */
+       dpd = bcm63xx_voip_dsp_device.dev.platform_data;
+       memcpy(dpd, pd, sizeof (*pd));
+
+       return platform_device_register(&bcm63xx_voip_dsp_device);
+}
diff --git a/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/bcm63xx_dev_dsp.h b/target/linux/brcm63xx/files/include/asm-mips/mach-bcm63xx/bcm63xx_dev_dsp.h
new file mode 100644 (file)
index 0000000..b587d45
--- /dev/null
@@ -0,0 +1,13 @@
+#ifndef __BCM63XX_DSP_H
+#define __BCM63XX_DSP_H
+
+struct bcm63xx_dsp_platform_data {
+       unsigned gpio_rst;
+       unsigned gpio_int;
+       unsigned cs;
+       unsigned ext_irq;
+};
+
+int __init bcm63xx_dsp_register(const struct bcm63xx_dsp_platform_data *pd);
+
+#endif /* __BCM63XX_DSP_H */
index 2f357fa87ef12598648b3fc8a38f67c46f1ba64e..85d1e5f418c55e49aebc387c3f30230b20b34148 100644 (file)
@@ -3,6 +3,7 @@
 
 #include <linux/types.h>
 #include <bcm63xx_dev_enet.h>
 
 #include <linux/types.h>
 #include <bcm63xx_dev_enet.h>
+#include <bcm63xx_dev_dsp.h>
 
 /*
  * flash mapping
 
 /*
  * flash mapping
@@ -42,10 +43,14 @@ struct board_info {
        unsigned int    has_ohci0:1;
        unsigned int    has_ehci0:1;
        unsigned int    has_udc0:1;
        unsigned int    has_ohci0:1;
        unsigned int    has_ehci0:1;
        unsigned int    has_udc0:1;
+       unsigned int    has_dsp:1;
 
        /* ethernet config */
        struct bcm63xx_enet_platform_data enet0;
        struct bcm63xx_enet_platform_data enet1;
 
        /* ethernet config */
        struct bcm63xx_enet_platform_data enet0;
        struct bcm63xx_enet_platform_data enet1;
+
+       /* DSP config */
+       struct bcm63xx_dsp_platform_data dsp;
 };
 
 #endif /* ! BOARD_BCM963XX_H_ */
 };
 
 #endif /* ! BOARD_BCM963XX_H_ */