build: fix CONFIG_AUTOREMOVE for packages with multiple variants
authorFelix Fietkau <nbd@nbd.name>
Sun, 22 Jan 2017 16:40:29 +0000 (17:40 +0100)
committerFelix Fietkau <nbd@nbd.name>
Sun, 22 Jan 2017 16:40:31 +0000 (17:40 +0100)
Calling the clean target removes all .ipk files and un-stages the
package. Add a new target just for clearing the build dir and call that
one instead of the full clean target

Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/host-build.mk
include/package.mk
include/subdir.mk

index 6a335fcbc3b1fe62e4b18f7e2f7f1b590e8b1c1c..d96cc94fa3c6d12f6eb2cf5c95579497a314e8d5 100644 (file)
@@ -176,15 +176,20 @@ ifndef DUMP
       $(t): host-$(t)
       .$(t): .host-$(t)
     )
+    clean-build: host-clean-build
   endif
 
   $(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
   $(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
   $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
-  host-clean: FORCE
+
+  host-clean-build: FORCE
+       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
+
+  host-clean: host-clean-build
        $(call Host/Clean)
        $(call Host/Uninstall)
-       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
+       rm -rf $(HOST_STAMP_INSTALLED)
 
     ifneq ($(CONFIG_AUTOREMOVE),)
       host-compile:
index 95b5f76dc3895e88c8115876c4c97359193cc9c6..fc2733907ed57d1f0da9579addd71256a018ed83 100644 (file)
@@ -300,12 +300,14 @@ compile: prepare-package-install
 .install: .compile
 install: compile
 
-clean: FORCE
+clean-build: FORCE
+       rm -rf $(PKG_BUILD_DIR)
+
+clean: clean-build
        $(CleanStaging)
        $(call Build/UninstallDev,$(STAGING_DIR),$(STAGING_DIR_HOST))
        $(Build/Clean)
        rm -f $(STAGING_DIR)/packages/$(STAGING_FILES_LIST) $(STAGING_DIR_HOST)/packages/$(STAGING_FILES_LIST)
-       rm -rf $(PKG_BUILD_DIR)
 
 dist:
        $(Build/Dist)
index e76a01e18ab885466b45734831c3c737c4c823d0..6bbf23a492289876382a76679c47759c80bc8fe4 100644 (file)
@@ -52,7 +52,7 @@ rebuild_check = \
                $(if $(BUILD_LOG),mkdir -p $(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4));) \
                $$(NO_TRACE_MAKE) $(if $(BUILD_LOG),-d) -q $(subdir_make_opts) .$(if $(3),$(3)-)$(2) \
                        > $(if $(BUILD_LOG),$(BUILD_LOG_DIR)/$(1)$(if $(4),/$(4))/check-$(if $(3),$(3)-)$(2).txt,/dev/null) 2>&1 || \
-                       $$(SUBMAKE) $(subdir_make_opts) clean >/dev/null 2>/dev/null
+                       $$(SUBMAKE) $(subdir_make_opts) clean-build >/dev/null 2>/dev/null
 
 endif