build: image: fix build breakage of some images
authorPetr Štetiar <ynezz@true.cz>
Tue, 5 Nov 2019 22:57:37 +0000 (23:57 +0100)
committerPetr Štetiar <ynezz@true.cz>
Fri, 8 Nov 2019 10:02:18 +0000 (11:02 +0100)
Commit 881ed09ee6e2 ("build: create JSON files containing image info")
has removed the crucial empty new line from the image copy step
resulting in the following errors during make function expansion:

 GZ_SUFFIX :=
 bash: GZ_SUFFIX: command not found
 Makefile:86: recipe for target 'openwrt-ath79-generic-tplink_archer-c7-v5-squashfs-sysupgrade.bin' failed

Fixes: 881ed09ee6e2 ("build: create JSON files containing image info")
Signed-off-by: Petr Štetiar <ynezz@true.cz>
include/image.mk

index 940ae812ea950c8ddbc16a0532b5a903d532473c..77d456719711022e3cbea3cad296087385ddf1f9 100644 (file)
@@ -597,6 +597,7 @@ define Device/Build/image
                SUPPORTED_DEVICES="$(SUPPORTED_DEVICES)" \
                $(TOPDIR)/scripts/json_add_image_info.py \
        )
+
 endef
 
 define Device/Build/artifact