Add offline_root option to ipkg.conf
authorNicolas Thill <nico@openwrt.org>
Sun, 6 Mar 2005 11:00:35 +0000 (11:00 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 6 Mar 2005 11:00:35 +0000 (11:00 +0000)
SVN-Revision: 312

openwrt/toolchain/ipkg-utils/Makefile

index 9568e8f758a533b2f67815930b6528320db2b5be..0cfe3c06e44441f82b9511a464d668e5584d3620 100644 (file)
@@ -31,9 +31,9 @@ $(PKG_BUILD_DIR)/.patched: $(PKG_BUILD_DIR)/.unpacked
 
 $(STAGING_DIR)/usr/bin/ipkg-build: $(PKG_BUILD_DIR)/.patched
        mkdir -p $(STAGING_DIR)/etc
-       echo "dest root $(TARGET_DIR)" > $(STAGING_DIR)/etc/ipkg.conf
+       echo "dest root /" > $(STAGING_DIR)/etc/ipkg.conf
+       echo "option offline_root $(TARGET_DIR)" >> $(STAGING_DIR)/etc/ipkg.conf
        mkdir -p $(STAGING_DIR)/usr/bin
-       install -m0755 $(TARGET_DIR)/bin/ipkg $(STAGING_DIR)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/ipkg-build $(STAGING_DIR)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/ipkg-buildpackage $(STAGING_DIR)/usr/bin
        install -m0755 $(PKG_BUILD_DIR)/ipkg-make-index $(STAGING_DIR)/usr/bin