musl: allow autorebuild
authorFelix Fietkau <nbd@nbd.name>
Wed, 24 Jan 2018 15:43:28 +0000 (16:43 +0100)
committerFelix Fietkau <nbd@nbd.name>
Thu, 25 Jan 2018 09:54:14 +0000 (10:54 +0100)
Autorebuild is disabled for the toolchain to avoid build-order issues.
However, rebuilding musl is safe, so exclude it from that restriction.
Avoids the need for manual cleaning on kernel header <-> libc API
changes like the ones introduced recently

Signed-off-by: Felix Fietkau <nbd@nbd.name>
toolchain/musl/common.mk

index 8350197a9f7b8e581723591fefffdbbc3d378ab5..4b53d4b556c80149d854389434006bf4f41532cc 100644 (file)
@@ -21,9 +21,11 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 LIBC_SO_VERSION:=$(PKG_VERSION)
 PATCH_DIR:=$(PATH_PREFIX)/patches
 
+BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+HOST_BUILD_PREFIX:=$(TOOLCHAIN_DIR)
 HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
 
-include $(INCLUDE_DIR)/toolchain-build.mk
+include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/hardening.mk
 
 MUSL_CONFIGURE:= \