update acx-mac80211 to 20101030 snapshot, patch from sn9
authorFlorian Fainelli <florian@openwrt.org>
Thu, 25 Nov 2010 11:57:48 +0000 (11:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 25 Nov 2010 11:57:48 +0000 (11:57 +0000)
SVN-Revision: 24137

package/acx-mac80211/Makefile
package/acx-mac80211/patches/001-wlan_cipher_suite.patch [deleted file]

index 44aede277555ba0096abcc5aa5c0d79b05d0d2c7..775e678208673f9fde45f7d472bc7210a1b97d4e 100644 (file)
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=acx-mac80211
-PKG_REV:=6130cd9c7c07e1a5babf53f7f89e70e5844c2d08
-PKG_VERSION:=20100830
+PKG_REV:=06f0acf66d53ea422e9c1bd6b475f13818d94f20
+PKG_VERSION:=20101030
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -72,7 +72,7 @@ define Build/Compile
                CROSS_COMPILE="$(TARGET_CROSS)" \
                SUBDIRS="$(PKG_BUILD_DIR)" \
                $(PKG_EXTRA_KCONFIG) \
-               EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(2,6,34)\"" \
+               EXTRA_CFLAGS="$(PKG_EXTRA_CFLAGS) -DCONFIG_ACX_MAC80211_VERSION=\"KERNEL_VERSION(2,6,37)\"" \
                LINUXINCLUDE="-I$(STAGING_DIR)/usr/include/mac80211 -I$(LINUX_DIR)/include \
                        -Iarch/$(LINUX_KARCH)/include \
                        -include $(LINUX_AUTOCONF_FILE) \
diff --git a/package/acx-mac80211/patches/001-wlan_cipher_suite.patch b/package/acx-mac80211/patches/001-wlan_cipher_suite.patch
deleted file mode 100644 (file)
index f9d9409..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/common.c b/common.c
-index 69cdf5b..28b3750 100644
---- a/common.c
-+++ b/common.c
-@@ -5765,8 +5765,9 @@ int acx_e_op_set_key(struct ieee80211_hw *hw, enum set_key_cmd cmd,
-        * TODO WEP hw support can still be added later, if required.
-        */
--      switch (key->alg) {
--      case ALG_WEP:
-+      switch (key->cipher) {
-+      case WLAN_CIPHER_SUITE_WEP40:
-+      case WLAN_CIPHER_SUITE_WEP104:
-               if (key->keylen == 5) {
-                       algorithm = ACX_SEC_ALGO_WEP;
-                       log(L_INIT, "acx: %s: algorithm=%i: %s\n", __func__, algorithm, "ACX_SEC_ALGO_WEP");
-@@ -5778,14 +5779,14 @@ int acx_e_op_set_key(struct ieee80211_hw *hw, enum set_key_cmd cmd,
-               err = -EOPNOTSUPP;
-               break;
--      case ALG_TKIP:
-+      case WLAN_CIPHER_SUITE_TKIP:
-               algorithm = ACX_SEC_ALGO_TKIP;
-               log(L_INIT, "acx: %s: algorithm=%i: %s\n", __func__, algorithm, "ACX_SEC_ALGO_TKIP");
-               err = -EOPNOTSUPP;
-               break;
-               break;
--      case ALG_CCMP:
-+      case WLAN_CIPHER_SUITE_CCMP:
-               algorithm = ACX_SEC_ALGO_AES;
-               log(L_INIT, "acx: %s: algorithm=%i: %s\n", __func__, algorithm, "ACX_SEC_ALGO_AES");
-               err = -EOPNOTSUPP;