package/ifxmips-dsl-api: move configuration in submenu
authorNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 11:10:37 +0000 (11:10 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 16 Apr 2010 11:10:37 +0000 (11:10 +0000)
SVN-Revision: 20922

package/ifxmips-dsl-api/Config.in
package/ifxmips-dsl-api/Makefile

index 56177d16894e0e5d75fb743a9f4ab519b1d6eaeb..72942e6fff75480d3f33381dac3399c85c07395b 100644 (file)
@@ -1,6 +1,8 @@
+menu "Configuration"
+       depends on PACKAGE_kmod-ifxmips-dsl-api
+
 choice
        prompt "Firmware"
-       depends on PACKAGE_kmod-ifxmips-dsl-api
        default IFXMIPS_ANNEX_B
        help
          This option controls which firmware is loaded
@@ -20,12 +22,12 @@ endchoice
 config IFXMIPS_DSL_FIRMWARE
        bool "ifxmips-dsl firmware extractor"
        default y
-       depends on PACKAGE_kmod-ifxmips-dsl-api
        help
          Say Y, if you need ifxmips-dsl to auto extract the firmware for you from the a800 firmware image
 
 config IFXMIPS_DSL_DEBUG
        bool "ifxmips-dsl debugging"
-       depends on PACKAGE_kmod-ifxmips-dsl-api
        help
          Say Y, if you need ifxmips-dsl to display debug messages.
+
+endmenu
index c0e1cea085da366d72a19448bb79ec17820dd123..a5cd221a5a983c14ebd4f881292f2d73d44b29f2 100644 (file)
@@ -39,6 +39,7 @@ define KernelPackage/ifxmips-dsl-api
        $(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.$(LINUX_KMOD_SUFFIX) \
        $(PKG_BUILD_DIR)/src/mei/ifxmips_atm.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,ifxmips_mei drv_dsl_cpe_api ifxmips_atm)
+  MENU:=1
 endef
 
 define KernelPackage/ifxmips-dsl-api/description