iproute2: re-enable PIC, it is only applied to libnetlink.a and required for collectd
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 2 Jul 2014 12:41:36 +0000 (12:41 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 2 Jul 2014 12:41:36 +0000 (12:41 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 41460

package/network/utils/iproute2/Makefile

index 558855ff4cdb8317fc961bd527b55792d8f4813d..fc47159b0d9777ba908d8dd8cd8150d1a98ee635 100644 (file)
@@ -86,7 +86,7 @@ MAKE_FLAGS += \
        SHARED_LIBS="" \
        LDFLAGS="-Wl,--gc-sections" \
        IP_CONFIG_TINY=$(IP_CONFIG_TINY) \
-       FPIC=""
+       FPIC="$(FPIC)"
 
 define Build/Compile
        +$(MAKE_VARS) $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) $(MAKE_FLAGS)