brcm63xx: move bcm963268bu_p300 to dts
authorJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:35:24 +0000 (15:35 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 25 Mar 2015 15:35:24 +0000 (15:35 +0000)
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 44987

31 files changed:
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/dts/bcm963268bu_p300.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
target/linux/brcm63xx/patches-3.14/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/patches-3.14/568-board_DGND3700v1_3800B.patch
target/linux/brcm63xx/patches-3.14/810-BCM63XX-move-kernel-behind-CFE.patch
target/linux/brcm63xx/patches-3.18/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
target/linux/brcm63xx/patches-3.18/511-board_V2500V.patch
target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
target/linux/brcm63xx/patches-3.18/566-board_A4001N.patch
target/linux/brcm63xx/patches-3.18/567-board_dsl-2751b_e1.patch
target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch
target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch
target/linux/brcm63xx/patches-3.18/810-BCM63XX-move-kernel-behind-CFE.patch
target/linux/brcm63xx/profiles/broadcom.mk [new file with mode: 0644]

index 9c8a612039860151668743a1b006a5af5d1da63a..3b0b667aa65e1a7a446ec691d2c3d8328d7fdb70 100755 (executable)
@@ -30,6 +30,9 @@ brcm63xx_dt_detect() {
        "Broadcom 96348R reference board")
                board_name="bcm96348r"
                ;;
+       "Broadcom BCM963268BU_P300 reference board")
+               board_name="bcm963268bu_p300"
+               ;;
        "Broadcom bcm963281TAN reference board")
                board_name="bcm963281tan"
                ;;
@@ -207,9 +210,6 @@ brcm63xx_legacy_detect() {
        local board_name
 
        case "$1" in
-       963268BU_P300)
-               board_name="bcm963268bu_p300"
-               ;;
        96338W2_E7T)
                board_name="dsl-2640u"
                ;;
diff --git a/target/linux/brcm63xx/dts/bcm963268bu_p300.dts b/target/linux/brcm63xx/dts/bcm963268bu_p300.dts
new file mode 100644 (file)
index 0000000..cbf63ef
--- /dev/null
@@ -0,0 +1,28 @@
+/dts-v1/;
+
+/include/ "bcm63268.dtsi"
+
+/ {
+       model = "Broadcom BCM963268BU_P300 reference board";
+       compatible = "brcm,bcm963268bu_p300", "brcm,bcm63268";
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               debounce-interval = <60>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 0 0>;
+                       linux,code = <0x198>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio1 1 0>;
+                       linux,code = <0x211>;
+               };
+        };
+};
index bae025f7d223a08ffada2560f8e602d25fbeaa85..8e423e5883d1915a7bf02b32beeb7bddf392fa84 100755 (executable)
@@ -275,6 +275,8 @@ $(eval $(call ImageDTB,CFEDTB,RG100A,RG100A,rg100a,96358VW2,6358,--block-size 0x
 $(eval $(call ImageDTB,CFEDTB,AR1004G,AR1004G,ar1004g,96348GW-10,6348))
 # Belkin F5D7633
 $(eval $(call ImageDTB,CFEDTB,F5D7633,F5D7633,f5d7633,96348GW-10,6348,--block-size 0x20000 --image-offset 0x20000))
+# Broadcom BCM963268BU_P300
+$(eval $(call ImageDTB,Dummy,BCM963268BU_P300,BCM963268BU_P300,bcm963268bu_p300,963268BU_P300,63268))
 # BT Home Hub 2.0 A
 $(eval $(call ImageDTB,CFEDTB,BTHOMEHUB2A,HomeHub2A,homehub2a,HOMEHUB2A,6358,--image-offset 0x20000 --block-size 0x20000))
 # BT Voyager V2500V, V2500V_SIP_CLUB, V2500V_AA
index 4384c9427fa5f38fff6f013fb42d2ca1ce385f4c..9c5688c79ea3e6793acf14b94305fecf60b49350 100644 (file)
@@ -9,12 +9,12 @@ for known boards.
 
 Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 ---
- arch/mips/bcm63xx/boards/board_bcm963xx.c |   35 +++++++++++++++++++++++++++++
- 1 file changed, 35 insertions(+)
+ arch/mips/bcm63xx/boards/board_bcm963xx.c |   34 +++++++++++++++++++++++++++++
+ 1 file changed, 34 insertions(+)
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -716,6 +716,49 @@ static const struct board_info __initcon
+@@ -716,6 +716,48 @@ static const struct board_info __initcon
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -58,7 +58,6 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +#ifdef CONFIG_BCM63XX_CPU_6368
 +#endif
 +#ifdef CONFIG_BCM63XX_CPU_63268
-+      { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
 +#endif
 +#endif /* CONFIG_OF */
        { },
index 99a684e28121b1ccac403a33923a29ac4b600317..692fba7158791fe6f3e2392c5a66a1a562a2db37 100644 (file)
@@ -44,7 +44,7 @@
        { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
        { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
-@@ -1181,6 +1204,22 @@ void __init board_bcm963xx_init(void)
+@@ -1180,6 +1203,22 @@ void __init board_bcm963xx_init(void)
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
index 2d144e5916e50a5e7ad5b42c159768fd3298a63c..f98c437efb3469895ad9119d325cc3d8d7eb4c2a 100644 (file)
@@ -88,7 +88,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
 +      { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+ #endif
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
 @@ -88,12 +88,25 @@ void __init board_early_setup(const stru
index 04dcf2030f38325fd16cb5facff0aa74b47c19be..7dfc7ab4e8d04017d27a289122d74a4cc7114be6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1925,6 +1925,131 @@ static struct board_info __initdata boar
+@@ -1925,6 +1925,66 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
 +                      },
 +              },
 +      },
-+
-+      .leds = {
-+              {
-+                      .name           = "963268BU_P300:green:power",
-+                      .gpio           = 20,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:red:power",
-+                      .gpio           = 21,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:internet",
-+                      .gpio           = 8,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:red:internet",
-+                      .gpio           = 2,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:adsl",
-+                      .gpio           = 3,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:wps",
-+                      .gpio           = 7,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:voip1",
-+                      .gpio           = 4,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:voip2",
-+                      .gpio           = 5,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:pots",
-+                      .gpio           = 6,
-+                      .active_low     = 1,
-+              },
-+      },
-+
-+      .buttons = {
-+              {
-+                      .desc           = "reset",
-+                      .gpio           = 32,
-+                      .type           = EV_KEY,
-+                      .code           = KEY_RESTART,
-+                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+              {
-+                      .desc           = "wps",
-+                      .gpio           = 33,
-+                      .type           = EV_KEY,
-+                      .code           = KEY_WPS_BUTTON,
-+                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+      },
 +};
 +
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -2175,6 +2300,7 @@ static const struct board_info __initcon
+@@ -2175,6 +2235,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
        &board_vw6339gu,
  #endif
+@@ -2255,6 +2316,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_63268
++      { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+ #endif
+ #endif /* CONFIG_OF */
+       { },
index 1cc35476bceb6e24ff5587cfa5bbc22c9c44fd62..eabf468be1ed1a20f677408a7eec1cfb05e0fb4d 100644 (file)
@@ -76,7 +76,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -2298,6 +2359,7 @@ static const struct board_info __initcon
+@@ -2233,6 +2294,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -2379,6 +2441,7 @@ static struct of_device_id const bcm963x
+@@ -2314,6 +2376,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
 +      { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
index a59979483033124134b5f9602311bf71de3d08cf..cfdeab8944a87ef4c6626c10f9b080149ff37683 100644 (file)
@@ -61,7 +61,7 @@
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -2359,6 +2413,7 @@ static const struct board_info __initcon
+@@ -2294,6 +2348,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2441,6 +2496,7 @@ static struct of_device_id const bcm963x
+@@ -2376,6 +2431,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 610db1ea3726b93da743820efa905bca4743e136..0bacc8cbeac3088a9639ea88e9e66573ee6fcfa3 100644 (file)
@@ -61,7 +61,7 @@
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -2414,6 +2468,7 @@ static const struct board_info __initcon
+@@ -2349,6 +2403,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2497,6 +2552,7 @@ static struct of_device_id const bcm963x
+@@ -2432,6 +2487,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index 9d08f39b9059dbca1cbd0a91c9259143b30450cc..89cb5d3519a00271badc876fcc1936e301f2c17a 100644 (file)
@@ -50,7 +50,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .expected_cpu_id                = 0x6368,
-@@ -2467,6 +2510,7 @@ static const struct board_info __initcon
+@@ -2402,6 +2445,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -2554,6 +2598,7 @@ static struct of_device_id const bcm963x
+@@ -2489,6 +2533,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
 +      { .compatible = "zyxel,p870hw-51a-v2", .data = &board_P870HW51A_V2, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
index c80392a1c4a16947e1f688dfadb3068f6dfe9e8a..01e11184119f95a2949b219688f879f60ebab83b 100644 (file)
@@ -38,7 +38,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -2494,6 +2525,7 @@ static const struct board_info __initcon
+@@ -2429,6 +2460,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
@@ -46,7 +46,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -2575,6 +2607,7 @@ static struct of_device_id const bcm963x
+@@ -2510,6 +2542,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index e89d03552b2fc9d04759746d2f87bf7f14450cac..b53867804b288a2c9395b388f2c5b28b7c3c9537 100644 (file)
@@ -51,7 +51,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -2476,6 +2520,7 @@ static const struct board_info __initcon
+@@ -2411,6 +2455,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
@@ -59,7 +59,7 @@
        &board_A4001N1,
        &board_dsl_274xb_f1,
        &board_FAST2704V2,
-@@ -2560,6 +2605,7 @@ static struct of_device_id const bcm963x
+@@ -2495,6 +2540,7 @@ static struct of_device_id const bcm963x
        { .compatible = "netgear,cvg834g", .data = &board_cvg834g, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
index 59458341cf88ae133f1f874bbc0064252b7b26ca..d7a6dfc7bcdd9b75ec23c7cca44ea49282251f56 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -2514,6 +2649,7 @@ static const struct board_info __initcon
+@@ -2449,6 +2584,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 3a203c2409240890e74a8054a487c9b37c6b65e2..de0b20d14b76b4334ee052be4c4c743cae91bf16 100644 (file)
@@ -49,7 +49,7 @@
  static struct sprom_fixup __initdata vr3025u_fixups[] = {
        { .offset = 97, .value = 0xfeb3 },
        { .offset = 98, .value = 0x1618 },
-@@ -2723,6 +2765,7 @@ static const struct board_info __initcon
+@@ -2658,6 +2700,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
@@ -57,7 +57,7 @@
        &board_P870HW51A_V2,
        &board_VR3025u,
        &board_VR3025un,
-@@ -2813,6 +2856,7 @@ static struct of_device_id const bcm963x
+@@ -2748,6 +2791,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 15970f19e49e9d99260f05b5f1c77efb0d2a9e04..b161edbd72e11c8509e7ed3d7428be7fee45b00e 100644 (file)
@@ -19,8 +19,6 @@ and the entry point to be called, so move the kernel to behind CFE.
  arch/mips/bcm63xx/Platform |    2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/arch/mips/bcm63xx/Platform b/arch/mips/bcm63xx/Platform
-index 5f86b2f..ee73f8f 100644
 --- a/arch/mips/bcm63xx/Platform
 +++ b/arch/mips/bcm63xx/Platform
 @@ -4,4 +4,4 @@
@@ -29,6 +27,3 @@ index 5f86b2f..ee73f8f 100644
                -I$(srctree)/arch/mips/include/asm/mach-bcm63xx/
 -load-$(CONFIG_BCM63XX)                := 0xffffffff80010000
 +load-$(CONFIG_BCM63XX)                := 0xffffffff80800000
--- 
-1.7.10.4
-
index 4384c9427fa5f38fff6f013fb42d2ca1ce385f4c..9c5688c79ea3e6793acf14b94305fecf60b49350 100644 (file)
@@ -9,12 +9,12 @@ for known boards.
 
 Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 ---
- arch/mips/bcm63xx/boards/board_bcm963xx.c |   35 +++++++++++++++++++++++++++++
- 1 file changed, 35 insertions(+)
+ arch/mips/bcm63xx/boards/board_bcm963xx.c |   34 +++++++++++++++++++++++++++++
+ 1 file changed, 34 insertions(+)
 
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -716,6 +716,49 @@ static const struct board_info __initcon
+@@ -716,6 +716,48 @@ static const struct board_info __initcon
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -58,7 +58,6 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 +#ifdef CONFIG_BCM63XX_CPU_6368
 +#endif
 +#ifdef CONFIG_BCM63XX_CPU_63268
-+      { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
 +#endif
 +#endif /* CONFIG_OF */
        { },
index 99a684e28121b1ccac403a33923a29ac4b600317..692fba7158791fe6f3e2392c5a66a1a562a2db37 100644 (file)
@@ -44,7 +44,7 @@
        { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
        { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
-@@ -1181,6 +1204,22 @@ void __init board_bcm963xx_init(void)
+@@ -1180,6 +1203,22 @@ void __init board_bcm963xx_init(void)
                val &= MPI_CSBASE_BASE_MASK;
        }
        boot_addr = (u8 *)KSEG1ADDR(val);
index 2d144e5916e50a5e7ad5b42c159768fd3298a63c..f98c437efb3469895ad9119d325cc3d8d7eb4c2a 100644 (file)
@@ -88,7 +88,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
 +      { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+ #endif
 --- a/arch/mips/bcm63xx/boards/board_common.c
 +++ b/arch/mips/bcm63xx/boards/board_common.c
 @@ -88,12 +88,25 @@ void __init board_early_setup(const stru
index 04dcf2030f38325fd16cb5facff0aa74b47c19be..7dfc7ab4e8d04017d27a289122d74a4cc7114be6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1925,6 +1925,131 @@ static struct board_info __initdata boar
+@@ -1925,6 +1925,66 @@ static struct board_info __initdata boar
   * known 63268/63269 boards
   */
  #ifdef CONFIG_BCM63XX_CPU_63268
 +                      },
 +              },
 +      },
-+
-+      .leds = {
-+              {
-+                      .name           = "963268BU_P300:green:power",
-+                      .gpio           = 20,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:red:power",
-+                      .gpio           = 21,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:internet",
-+                      .gpio           = 8,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:red:internet",
-+                      .gpio           = 2,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:adsl",
-+                      .gpio           = 3,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:wps",
-+                      .gpio           = 7,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:voip1",
-+                      .gpio           = 4,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:voip2",
-+                      .gpio           = 5,
-+                      .active_low     = 1,
-+              },
-+              {
-+                      .name           = "963268BU_P300:green:pots",
-+                      .gpio           = 6,
-+                      .active_low     = 1,
-+              },
-+      },
-+
-+      .buttons = {
-+              {
-+                      .desc           = "reset",
-+                      .gpio           = 32,
-+                      .type           = EV_KEY,
-+                      .code           = KEY_RESTART,
-+                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+              {
-+                      .desc           = "wps",
-+                      .gpio           = 33,
-+                      .type           = EV_KEY,
-+                      .code           = KEY_WPS_BUTTON,
-+                      .debounce_interval = BCM963XX_KEYS_DEBOUNCE_INTERVAL,
-+              },
-+      },
 +};
 +
  static struct board_info __initdata board_963269bhr = {
        .name                           = "963269BHR",
        .expected_cpu_id                = 0x63268,
-@@ -2175,6 +2300,7 @@ static const struct board_info __initcon
+@@ -2175,6 +2235,7 @@ static const struct board_info __initcon
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963269bhr,
        &board_vw6339gu,
  #endif
+@@ -2255,6 +2316,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_63268
++      { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+ #endif
+ #endif /* CONFIG_OF */
+       { },
index 1cc35476bceb6e24ff5587cfa5bbc22c9c44fd62..eabf468be1ed1a20f677408a7eec1cfb05e0fb4d 100644 (file)
@@ -76,7 +76,7 @@
  #endif /* CONFIG_BCM63XX_CPU_6368 */
  
  /*
-@@ -2298,6 +2359,7 @@ static const struct board_info __initcon
+@@ -2233,6 +2294,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -2379,6 +2441,7 @@ static struct of_device_id const bcm963x
+@@ -2314,6 +2376,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
 +      { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
index a59979483033124134b5f9602311bf71de3d08cf..cfdeab8944a87ef4c6626c10f9b080149ff37683 100644 (file)
@@ -61,7 +61,7 @@
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -2359,6 +2413,7 @@ static const struct board_info __initcon
+@@ -2294,6 +2348,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2441,6 +2496,7 @@ static struct of_device_id const bcm963x
+@@ -2376,6 +2431,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 610db1ea3726b93da743820efa905bca4743e136..0bacc8cbeac3088a9639ea88e9e66573ee6fcfa3 100644 (file)
@@ -61,7 +61,7 @@
  static struct b53_platform_data WAP5813n_b53_pdata = {
        .alias = "eth0",
  };
-@@ -2414,6 +2468,7 @@ static const struct board_info __initcon
+@@ -2349,6 +2403,7 @@ static const struct board_info __initcon
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2497,6 +2552,7 @@ static struct of_device_id const bcm963x
+@@ -2432,6 +2487,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index 9d08f39b9059dbca1cbd0a91c9259143b30450cc..89cb5d3519a00271badc876fcc1936e301f2c17a 100644 (file)
@@ -50,7 +50,7 @@
  static struct board_info __initdata board_VR3025u = {
        .name                                   = "96368M-1541N",
        .expected_cpu_id                = 0x6368,
-@@ -2467,6 +2510,7 @@ static const struct board_info __initcon
+@@ -2402,6 +2445,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -2554,6 +2598,7 @@ static struct of_device_id const bcm963x
+@@ -2489,6 +2533,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
 +      { .compatible = "zyxel,p870hw-51a-v2", .data = &board_P870HW51A_V2, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
+       { .compatible = "brcm,bcm963268bu_p300", .data = &board_963268bu_p300, },
index c80392a1c4a16947e1f688dfadb3068f6dfe9e8a..01e11184119f95a2949b219688f879f60ebab83b 100644 (file)
@@ -38,7 +38,7 @@
  static struct board_info __initdata board_HW553 = {
        .name                           = "HW553",
        .expected_cpu_id                = 0x6358,
-@@ -2494,6 +2525,7 @@ static const struct board_info __initcon
+@@ -2429,6 +2460,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
@@ -46,7 +46,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -2575,6 +2607,7 @@ static struct of_device_id const bcm963x
+@@ -2510,6 +2542,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index e89d03552b2fc9d04759746d2f87bf7f14450cac..b53867804b288a2c9395b388f2c5b28b7c3c9537 100644 (file)
@@ -51,7 +51,7 @@
  static struct board_info __initdata board_A4001N1 = {
        .name                                   = "963281T_TEF",
        .expected_cpu_id                        = 0x6328,
-@@ -2476,6 +2520,7 @@ static const struct board_info __initcon
+@@ -2411,6 +2455,7 @@ static const struct board_info __initcon
        &board_AR5381u,
        &board_AR5387un,
        &board_963281TAN,
@@ -59,7 +59,7 @@
        &board_A4001N1,
        &board_dsl_274xb_f1,
        &board_FAST2704V2,
-@@ -2560,6 +2605,7 @@ static struct of_device_id const bcm963x
+@@ -2495,6 +2540,7 @@ static struct of_device_id const bcm963x
        { .compatible = "netgear,cvg834g", .data = &board_cvg834g, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6328
index 59458341cf88ae133f1f874bbc0064252b7b26ca..d7a6dfc7bcdd9b75ec23c7cca44ea49282251f56 100644 (file)
  #endif /* CONFIG_BCM63XX_CPU_6318 */
  
  /*
-@@ -2514,6 +2649,7 @@ static const struct board_info __initcon
+@@ -2449,6 +2584,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6318
        &board_96318ref,
        &board_96318ref_p300,
index 3a203c2409240890e74a8054a487c9b37c6b65e2..de0b20d14b76b4334ee052be4c4c743cae91bf16 100644 (file)
@@ -49,7 +49,7 @@
  static struct sprom_fixup __initdata vr3025u_fixups[] = {
        { .offset = 97, .value = 0xfeb3 },
        { .offset = 98, .value = 0x1618 },
-@@ -2723,6 +2765,7 @@ static const struct board_info __initcon
+@@ -2658,6 +2700,7 @@ static const struct board_info __initcon
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
@@ -57,7 +57,7 @@
        &board_P870HW51A_V2,
        &board_VR3025u,
        &board_VR3025un,
-@@ -2813,6 +2856,7 @@ static struct of_device_id const bcm963x
+@@ -2748,6 +2791,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index 2f3a02a6774566a0ab8456631993628aba3a0383..62b06d99645c4d359a758fe68c86b2af200e54a8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
 +++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1748,6 +1748,32 @@
+@@ -1748,6 +1748,32 @@ static struct board_info __initdata boar
        },
  };
  
@@ -33,7 +33,7 @@
  static struct board_info __initdata board_HW520 = {
        .name                           = "HW6358GW_B",
        .expected_cpu_id                = 0x6358,
-@@ -2748,6 +2774,7 @@
+@@ -2683,6 +2709,7 @@ static const struct board_info __initcon
        &board_nb4_ser_r0,
        &board_nb4_fxc_r1,
        &board_ct6373_1,
@@ -41,7 +41,7 @@
        &board_HW520,
        &board_HW553,
        &board_HW556_A,
-@@ -2845,6 +2872,7 @@
+@@ -2780,6 +2807,7 @@ static struct of_device_id const bcm963x
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
index 15970f19e49e9d99260f05b5f1c77efb0d2a9e04..b161edbd72e11c8509e7ed3d7428be7fee45b00e 100644 (file)
@@ -19,8 +19,6 @@ and the entry point to be called, so move the kernel to behind CFE.
  arch/mips/bcm63xx/Platform |    2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/arch/mips/bcm63xx/Platform b/arch/mips/bcm63xx/Platform
-index 5f86b2f..ee73f8f 100644
 --- a/arch/mips/bcm63xx/Platform
 +++ b/arch/mips/bcm63xx/Platform
 @@ -4,4 +4,4 @@
@@ -29,6 +27,3 @@ index 5f86b2f..ee73f8f 100644
                -I$(srctree)/arch/mips/include/asm/mach-bcm63xx/
 -load-$(CONFIG_BCM63XX)                := 0xffffffff80010000
 +load-$(CONFIG_BCM63XX)                := 0xffffffff80800000
--- 
-1.7.10.4
-
diff --git a/target/linux/brcm63xx/profiles/broadcom.mk b/target/linux/brcm63xx/profiles/broadcom.mk
new file mode 100644 (file)
index 0000000..54eed76
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BCM963268BU_P300
+  NAME:=Broadcom BCM96328BU_P300 reference board
+  PACKAGES:= kmod-usb-ohci kmod-usb2 kmod-bcm63xx-udc
+endef
+define Profile/BCM963268BU_P300/Description
+  Package set optimized for the Broadcom BCM963268BU_P300 reference boar.
+endef
+$(eval $(call Profile,BCM963268BU_P300))