iproute2: add package for bridge program
authorSteven Barth <cyrus@openwrt.org>
Sat, 17 Jan 2015 10:58:34 +0000 (10:58 +0000)
committerSteven Barth <cyrus@openwrt.org>
Sat, 17 Jan 2015 10:58:34 +0000 (10:58 +0000)
The 'bridge' program has been part of iproute2 for a while, and it was once
declared[1] to the the intended longterm replacement for bridge-utils, but
its features are still mostly distinct[2] from the venerable brctl.

[1] http://lwn.net/Articles/435845/
[2] http://sgros-students.blogspot.com/2013/11/comparison-of-brctl-and-bridge-commands.html

Signed-off-by: Russell Senior <russell@personaltelco.net>
SVN-Revision: 43993

package/network/utils/iproute2/Makefile

index a49b0616ea795939bc053d15ae91ff0e08a6c17c..ad14ac4484ba63a4506fec57ad8a5b467fb5e906 100644 (file)
@@ -58,6 +58,11 @@ $(call Package/iproute2/Default)
   TITLE:=General netlink utility frontend
 endef
 
+define Package/ip-bridge
+$(call Package/iproute2/Default)
+  TITLE:=Bridge configuration utility from iproute2
+endef
+
 define Package/ss
 $(call Package/iproute2/Default)
   TITLE:=Socket statistics utility
@@ -130,6 +135,11 @@ define Package/genl/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/genl/genl $(1)/usr/sbin/
 endef
 
+define Package/ip-bridge/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bridge/bridge $(1)/usr/sbin/
+endef
+
 define Package/ss/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/misc/ss $(1)/usr/sbin/
@@ -139,4 +149,5 @@ $(eval $(call BuildPackage,ip))
 $(eval $(call BuildPackage,ip-full))
 $(eval $(call BuildPackage,tc))
 $(eval $(call BuildPackage,genl))
+$(eval $(call BuildPackage,ip-bridge))
 $(eval $(call BuildPackage,ss))