mac80211: remove header files used to share struct with platform code.
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 5 Aug 2012 23:43:36 +0000 (23:43 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 5 Aug 2012 23:43:36 +0000 (23:43 +0000)
The structs defined in these header files should be the same as the
structes used by the platform code otherwise it will cause strange
runtime errors. By removing them from compat-wireless we will get a
compile error instead of a runtime error if they are out of sync.

SVN-Revision: 33006

package/mac80211/Makefile

index a6738af768b6d1b9a069cf8df78b5b1662dbf0c3..f1a797e607391da253da9153f64e741e4a4330d8 100644 (file)
@@ -1329,7 +1329,13 @@ define Build/Prepare
        $(TAR) -C $(PKG_BUILD_DIR) -xjf $(DL_DIR)/$(PKG_LINUX_FIRMWARE_SOURCE)
        rm -rf $(PKG_BUILD_DIR)/include/linux/ssb
        rm -rf $(PKG_BUILD_DIR)/include/linux/bcma
+       rm -rf $(PKG_BUILD_DIR)/include/net/bluetooth/
        rm -f $(PKG_BUILD_DIR)/include/linux/eeprom_93cx6.h
+       rm -f $(PKG_BUILD_DIR)/include/linux/ath9k_platform.h
+       rm -f $(PKG_BUILD_DIR)/include/linux/ath5k_platform.h
+       rm -f $(PKG_BUILD_DIR)/include/linux/rt2x00_platform.h
+       rm -f $(PKG_BUILD_DIR)/include/linux/wl12xx.h
+       rm -f $(PKG_BUILD_DIR)/include/linux/spi/libertas_spi.h
        rm -f $(PKG_BUILD_DIR)/include/net/ieee80211.h
        echo 'compat-wireless-$(PKG_VERSION)-$(PKG_RELEASE)-$(REVISION)' > $(PKG_BUILD_DIR)/compat_version
        $(CP) ./files/regdb.txt $(PKG_BUILD_DIR)/net/wireless/db.txt