am33x-cm3: remove
authorAndre Heider <a.heider@gmail.com>
Thu, 3 Oct 2019 16:11:17 +0000 (18:11 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Wed, 20 Nov 2019 09:49:01 +0000 (10:49 +0100)
This is currently unused and not working anyway, since the used upstream
kernel loads am335x-pm-firmware.elf and not am335x-pm-firmware.bin [0].

The last downstream patches using the latter were removed with e4eef7e6.

Remove it instead of fixing it since the rtc-only sleep state can even
damage the hardware [1].

[0] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ccbbb9faac946ce61c241ce9f08b3486fabf031d
[1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7a6cb0abe1aa63334f3ded6d2b6c8eca80e72302

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/firmware/am33x-cm3/Makefile [deleted file]

diff --git a/package/firmware/am33x-cm3/Makefile b/package/firmware/am33x-cm3/Makefile
deleted file mode 100644 (file)
index e392358..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=am33x-cm3
-PKG_VERSION:=20130304
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=http://arago-project.org/git/projects/am33x-cm3.git
-PKG_SOURCE_VERSION:=32cf44e25b5828b87af6dceebc3a49fed5d858ac
-PKG_MIRROR_HASH:=71d4029eed4ef58a1e0beb299d5c876bf0b9a790ecac52aacf1d510f5841d959
-
-PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-
-PKG_FLAGS:=nonshared
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/am33x-cm3
-  SECTION:=firmware
-  CATEGORY:=Firmware
-  URL:=http://arago-project.org/git/projects/?p=am33x-cm3.git
-  TITLE:=TI AM335x PM firmware
-  DEPENDS:=@TARGET_omap
-endef
-
-define Build/Compile
-       $(MAKE) CROSS_COMPILE=$(TARGET_CROSS) -C $(PKG_BUILD_DIR)
-endef
-
-define Package/am33x-cm3/install
-       $(INSTALL_DIR) $(1)/lib/firmware
-       $(CP) $(PKG_BUILD_DIR)/bin/am335x-pm-firmware.bin $(1)/lib/firmware
-endef
-
-$(eval $(call BuildPackage,am33x-cm3))