ath79: prepare NAND subtarget for upstream support of SPI NAND
authorJeff Kletsky <git-commits@allycomm.com>
Tue, 14 May 2019 16:47:40 +0000 (09:47 -0700)
committerChuanhong Guo <gch981213@gmail.com>
Thu, 14 Nov 2019 06:38:58 +0000 (14:38 +0800)
Linux 4.19 supplies the upstream spi-nand framework,
permitting porting and support of boards with SPI NAND.

  * Adjusted nand/target.mk to provide FEATURES += squashfs nand

  * Updated config-default to provide current MTD and UBI support

Defaults selected for:

  CONFIG_MTD_UBI_WL_THRESHOLD=4096
  CONFIG_MTD_UBI_BEB_LIMIT=20
  # CONFIG_MTD_UBI_FASTMAP is not set
  # CONFIG_MTD_UBI_GLUEBI is not set

The bad-block reservation limit technically should be 21 for Paragon
SPI NAND but most other devices in the class are 20 blocks per Gbit.
In Linux 5.2 this is specified on a per-chip basis through NAND_MEMORG

Contents adjusted to remove declarations provided at the target level
by commit 08a134820f5 (Oct 23, 2019) ath79: enable PCI for whole target

Signed-off-by: Jeff Kletsky <git-commits@allycomm.com>
Tested-by: Michal Cieslakiewicz <michal.cieslakiewicz@wp.pl>
target/linux/ath79/nand/config-default
target/linux/ath79/nand/target.mk

index 84e6748a20e3e511f04cb6eb65a71cf4dfde0e93..4742ad52d065921a7369f0d06a12dd13c8c4de7b 100644 (file)
@@ -1,18 +1,17 @@
-CONFIG_AT803X_PHY=y
-CONFIG_BCH=y
 CONFIG_MTD_NAND=y
 CONFIG_MTD_NAND_AR934X=y
-CONFIG_MTD_NAND_BCH=y
+CONFIG_MTD_NAND_CORE=y
 CONFIG_MTD_NAND_ECC=y
-CONFIG_MTD_NAND_ECC_BCH=y
-CONFIG_MTD_SPINAND_MT29F=y
-CONFIG_MTD_SPINAND_ONDIEECC=y
+CONFIG_MTD_SPI_NAND=y
 CONFIG_MTD_UBI=y
-CONFIG_MTD_UBI_BEB_LIMIT=20
 CONFIG_MTD_UBI_BLOCK=y
+CONFIG_MTD_UBI_WL_THRESHOLD=4096
+CONFIG_MTD_UBI_BEB_LIMIT=20
 # CONFIG_MTD_UBI_FASTMAP is not set
 # CONFIG_MTD_UBI_GLUEBI is not set
-CONFIG_MTD_UBI_WL_THRESHOLD=4096
+# CONFIG_PCI_AR71XX is not set
+# CONFIG_PHY_AR7100_USB is not set
+CONFIG_PHY_AR7200_USB=y
 CONFIG_UBIFS_FS=y
 CONFIG_UBIFS_FS_ADVANCED_COMPR=y
 CONFIG_UBIFS_FS_LZO=y
index 91afe675c51a31d5c329375cd524b6bce95350a7..c565c9b2b8c45136ce7b04b8ea65fd55330cfc52 100644 (file)
@@ -1,9 +1,10 @@
 BOARDNAME := Generic devices with NAND flash
-FEATURES += squashfs nand rtc
+
+FEATURES += squashfs nand
 
 DEFAULT_PACKAGES += wpad-basic
 
 define Target/Description
-       Build firmware for Atheros AR71xx/AR913x based boards with
-       NAND flash, e.g. Netgear WNDR4300.
+       Firmware for boards using Qualcomm Atheros, MIPS-based SoCs
+       in the ar72xx and subsequent series, with support for NAND flash
 endef