firewall: fix several ipset integration issues (#15016)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 20 Feb 2014 23:20:10 +0000 (23:20 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 20 Feb 2014 23:20:10 +0000 (23:20 +0000)
- Do not consider bitmap storage for IPv6 family sets
- Move ipset family parameter before any additional option
- Only emit family parameter for hash sets
- Do not allow IPv6 iprange for IPv4 sets and vice versa

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 39647

package/network/config/firewall/Makefile

index 872f217e181b771c3169080cafa1d0b154e23553..8c851641e7983305b5b4c48cadef7327998dda63 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=firewall
-PKG_VERSION:=2013-12-17
+PKG_VERSION:=2014-02-21
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/firewall3.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=8002b8454f9e33042aec8b9ab6346f3a4dd92994
+PKG_SOURCE_VERSION:=7dfc240dfaee099eab04bd18369edb11dfbb5045
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>