uclient: install a symlink from uclient-fetch to wget into /bin
authorFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 22:41:31 +0000 (22:41 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 19 Jan 2016 22:41:31 +0000 (22:41 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48379

package/libs/uclient/Makefile

index 7ed7ae2ff26910dd7323dccb091efe4ffdb7cd2d..bc5fc114cd70d56f33ec120026a35a34d392561b 100644 (file)
@@ -43,8 +43,9 @@ define Package/libuclient/install
 endef
 
 define Package/uclient-fetch/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uclient-fetch $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/uclient-fetch $(1)/bin/
+       ln -s uclient-fetch $(1)/bin/wget
 endef
 
 $(eval $(call BuildPackage,libuclient))