libselinux: remove dependency on musl-fts for non-musl builds
authorDaniel Golle <daniel@makrotopia.org>
Sat, 31 Oct 2020 00:06:53 +0000 (00:06 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 31 Oct 2020 00:49:43 +0000 (00:49 +0000)
Suggested-by: Curtis Deptuck <curtdept@users.noreply.github.com>
Tested-by: Curtis Deptuck <curtdept@users.noreply.github.com>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/libs/libselinux/Makefile

index 20d9225d392961dbc6191ba0851ab2e775fc366c..5fe745d00414e514d0105726688664a6efb0d1e4 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libselinux
 PKG_VERSION:=3.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/SELinuxProject/selinux/releases/download/20200710
@@ -69,7 +69,7 @@ define Package/libselinux
   $(call Package/libselinux/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libsepol +libpcre +musl-fts
+  DEPENDS:=+libsepol +libpcre +USE_MUSL:musl-fts
 endef
 
 define Package/libselinux/description
@@ -109,8 +109,11 @@ HOST_MAKE_FLAGS += \
        PREFIX=$(STAGING_DIR_HOSTPKG) \
        SHLIBDIR=$(STAGING_DIR_HOSTPKG)/lib
 
+ifeq ($(CONFIG_USE_MUSL),y)
+MAKE_FLAGS += FTS_LDLIBS=-lfts
+endif
+
 MAKE_FLAGS += \
-       FTS_LDLIBS=-lfts \
        SHLIBDIR=/usr/lib \
        OS=Linux