x86: add generic profiles to x86_64, kvm_guest and xen_domu
authorFelix Fietkau <nbd@openwrt.org>
Sun, 8 Nov 2015 20:39:24 +0000 (20:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 8 Nov 2015 20:39:24 +0000 (20:39 +0000)
The imagebuilder requires a profile for every subtarget to work.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 47421

target/linux/x86/64/profiles/000-Generic.mk [new file with mode: 0644]
target/linux/x86/kvm_guest/profiles/000-Generic.mk [new file with mode: 0644]
target/linux/x86/xen_domu/profiles/000-Generic.mk [new file with mode: 0644]

diff --git a/target/linux/x86/64/profiles/000-Generic.mk b/target/linux/x86/64/profiles/000-Generic.mk
new file mode 100644 (file)
index 0000000..ccd125a
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+       Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/kvm_guest/profiles/000-Generic.mk b/target/linux/x86/kvm_guest/profiles/000-Generic.mk
new file mode 100644 (file)
index 0000000..ccd125a
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+       Generic Profile
+endef
+$(eval $(call Profile,Generic))
diff --git a/target/linux/x86/xen_domu/profiles/000-Generic.mk b/target/linux/x86/xen_domu/profiles/000-Generic.mk
new file mode 100644 (file)
index 0000000..ccd125a
--- /dev/null
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2006-2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic
+endef
+
+define Profile/Generic/Description
+       Generic Profile
+endef
+$(eval $(call Profile,Generic))