ath79: add support for TP9343-based TP-Link TL-WR94x devices
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 24 Jul 2019 14:49:08 +0000 (16:49 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 20 May 2020 18:11:33 +0000 (20:11 +0200)
This adds support for several TP-Link devices based on TP9343
("a QCA9561 without PCIe and USB"):
- TL-WR940N v3
- TL-WR940N v4
- TL-WR941ND v6

The devices are only different concerning LEDs and MAC address
assignment.

All TL-WR940 are with non-detachable antennas (N), all
TL-WR941 devices are with detachable antennas (ND).

Specification:
- 750 MHz CPU
- 32 MB of RAM
- 4 MB of FLASH
- 2.4 GHz WiFi
- 4x 10/100 Mbps Ethernet

Flash instruction (WebUI):
Download *-factory.bin image and upload it via the firmwary upgrade
function of the stock firmware WebUI.

Flash instruction (TFTP):
1. Set PC to fixed ip address 192.168.0.66
2. Download *-factory.bin image and rename it to * (see below)
3. Start a tftp server with the image file in its root directory
4. Turn off the router
5. Press and hold Reset button
6. Turn on router with the reset button pressed and wait ~15 seconds
7. Release the reset button and after a short time
the firmware should be transferred from the tftp server
8. Wait ~30 second to complete recovery.

* TFTP image names:
940 v3: wr941ndv6_tp_recovery.bin
940 v4: wr940nv4_tp_recovery.bin
941 v6: wr941ndv6_tp_recovery.bin

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
(backported picked from commit c02b9818a51ab189be11218e626e9cad2c21ec94)

target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v3.dts [new file with mode: 0644]
target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v3.dtsi [new file with mode: 0644]
target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v4.dts [new file with mode: 0644]
target/linux/ath79/dts/tp9343_tplink_tl-wr941nd-v6.dts [new file with mode: 0644]
target/linux/ath79/dts/tp9343_tplink_tl-wr94x.dtsi [new file with mode: 0644]
target/linux/ath79/image/tiny-tp-link.mk

index e89152ab7e7af8634515db26ce03059f2dfe43a6..9894adfb7a9f0f4420b92b779a0edc0f4195c2ae 100755 (executable)
@@ -210,6 +210,15 @@ tplink,tl-wr842n-v2)
        ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x10"
        ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
        ;;
+tplink,tl-wr940n-v3|\
+tplink,tl-wr940n-v4|\
+tplink,tl-wr941nd-v6)
+       ucidef_set_led_netdev "wan" "WAN" "tp-link:blue:wan" "eth1"
+       ucidef_set_led_switch "lan1" "LAN1" "tp-link:blue:lan1" "switch0" "0x10"
+       ucidef_set_led_switch "lan2" "LAN2" "tp-link:blue:lan2" "switch0" "0x08"
+       ucidef_set_led_switch "lan3" "LAN3" "tp-link:blue:lan3" "switch0" "0x04"
+       ucidef_set_led_switch "lan4" "LAN4" "tp-link:blue:lan4" "switch0" "0x02"
+       ;;
 ubnt,bullet-m|\
 ubnt,bullet-m-xw|\
 ubnt,nanostation-loco-m|\
index 1b0e76b1593bfd38cfaea6dc4844ed9f222f0b6b..2c1f2a90d7271c1029d67f7c0e0686f2ebe23f58 100755 (executable)
@@ -89,6 +89,9 @@ ath79_setup_interfaces()
        tplink,tl-wr841-v12|\
        tplink,tl-wr842n-v1|\
        tplink,tl-wr842n-v3|\
+       tplink,tl-wr940n-v3|\
+       tplink,tl-wr940n-v4|\
+       tplink,tl-wr941nd-v6|\
        ubnt,airrouter)
                ucidef_set_interface_wan "eth1"
                ucidef_add_switch "switch0" \
diff --git a/target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v3.dts b/target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v3.dts
new file mode 100644 (file)
index 0000000..171cc60
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "tp9343_tplink_tl-wr940n-v3.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr940n-v3", "qca,tp9343";
+       model = "TP-Link TL-WR940N v3";
+};
diff --git a/target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v3.dtsi b/target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v3.dtsi
new file mode 100644 (file)
index 0000000..f5543e4
--- /dev/null
@@ -0,0 +1,69 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "tp9343_tplink_tl-wr94x.dtsi"
+
+/ {
+       aliases {
+               led-boot = &led_system;
+               led-failsafe = &led_system;
+               led-running = &led_system;
+               led-upgrade = &led_system;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_system: system {
+                       label = "tp-link:blue:system";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               qss {
+                       label = "tp-link:blue:qss";
+                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "tp-link:blue:wlan";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wan_blue {
+                       label = "tp-link:blue:wan";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_red {
+                       label = "tp-link:red:wan";
+                       gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+               };
+
+               lan1 {
+                       label = "tp-link:blue:lan1";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+               };
+
+               lan2 {
+                       label = "tp-link:blue:lan2";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               };
+
+               lan3 {
+                       label = "tp-link:blue:lan3";
+                       gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+               };
+
+               lan4 {
+                       label = "tp-link:blue:lan4";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&eth1 {
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <(-1)>;
+};
diff --git a/target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v4.dts b/target/linux/ath79/dts/tp9343_tplink_tl-wr940n-v4.dts
new file mode 100644 (file)
index 0000000..54e3555
--- /dev/null
@@ -0,0 +1,71 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "tp9343_tplink_tl-wr94x.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr940n-v4", "qca,tp9343";
+       model = "TP-Link TL-WR940N v4";
+
+       aliases {
+               led-boot = &led_system;
+               led-failsafe = &led_system;
+               led-running = &led_system;
+               led-upgrade = &led_system;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_system: system {
+                       label = "tp-link:blue:system";
+                       gpios = <&gpio 5 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               qss {
+                       label = "tp-link:blue:qss";
+                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "tp-link:blue:wlan";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wan_blue {
+                       label = "tp-link:blue:wan";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               wan_red {
+                       label = "tp-link:red:wan";
+                       gpios = <&gpio 15 GPIO_ACTIVE_HIGH>;
+               };
+
+               lan1 {
+                       label = "tp-link:blue:lan1";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               };
+
+               lan2 {
+                       label = "tp-link:blue:lan2";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               };
+
+               lan3 {
+                       label = "tp-link:blue:lan3";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+               };
+
+               lan4 {
+                       label = "tp-link:blue:lan4";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&eth1 {
+       mtd-mac-address = <&uboot 0x1fc00>;
+};
diff --git a/target/linux/ath79/dts/tp9343_tplink_tl-wr941nd-v6.dts b/target/linux/ath79/dts/tp9343_tplink_tl-wr941nd-v6.dts
new file mode 100644 (file)
index 0000000..121267f
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "tp9343_tplink_tl-wr940n-v3.dtsi"
+
+/ {
+       compatible = "tplink,tl-wr941nd-v6", "qca,tp9343";
+       model = "TP-Link TL-WR941ND v6";
+};
diff --git a/target/linux/ath79/dts/tp9343_tplink_tl-wr94x.dtsi b/target/linux/ath79/dts/tp9343_tplink_tl-wr94x.dtsi
new file mode 100644 (file)
index 0000000..a31508e
--- /dev/null
@@ -0,0 +1,89 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               wifi_button {
+                       label = "WiFi button";
+                       linux,code = <KEY_RFKILL>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+               };
+
+               reset_button {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               };
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot:  partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               compatible = "tplink,firmware";
+                               label = "firmware";
+                               reg = <0x020000 0x3d0000>;
+                       };
+
+                       art: partition@3f0000 {
+                               label = "art";
+                               reg = <0x3f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&uart {
+       status = "okay";
+};
+
+&eth0 {
+       status = "okay";
+
+       phy-mode = "mii";
+       phy-handle = <&swphy4>;
+
+       mtd-mac-address = <&uboot 0x1fc00>;
+       mtd-mac-address-increment = <1>;
+};
+
+&eth1 {
+       status = "okay";
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&uboot 0x1fc00>;
+};
index a2bedd244df478a7e978145a12077efe875be2e7..43be61368b606c0088775956dce2cd487ddd9c2f 100644 (file)
@@ -221,6 +221,28 @@ define Device/tplink_tl-wr841-v12
 endef
 TARGET_DEVICES += tplink_tl-wr841-v12
 
+define Device/tplink_tl-wr940n-v3
+  $(Device/tplink-4mlzma)
+  ATH_SOC := tp9343
+  DEVICE_TITLE := TP-Link TL-WR940N v3
+  TPLINK_HWID := 0x09410006
+  SUPPORTED_DEVICES += tl-wr941nd-v6
+endef
+TARGET_DEVICES += tplink_tl-wr940n-v3
+
+define Device/tplink_tl-wr940n-v4
+  $(Device/tplink-4mlzma)
+  ATH_SOC := tp9343
+  DEVICE_TITLE := TP-Link TL-WR940N v4
+  TPLINK_HWID := 0x09400004
+  SUPPORTED_DEVICES += tl-wr940n-v4
+  IMAGES += factory-us.bin factory-eu.bin factory-br.bin
+  IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
+  IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
+  IMAGE/factory-br.bin := append-rootfs | mktplinkfw factory -C BR
+endef
+TARGET_DEVICES += tplink_tl-wr940n-v4
+
 define Device/tplink_tl-wr941-v2
   $(Device/tplink-4m)
   ATH_SOC := ar9132
@@ -240,6 +262,15 @@ define Device/tplink_tl-wr941-v4
 endef
 TARGET_DEVICES += tplink_tl-wr941-v4
 
+define Device/tplink_tl-wr941nd-v6
+  $(Device/tplink-4mlzma)
+  ATH_SOC := tp9343
+  DEVICE_TITLE := TP-Link TL-WR941ND v6
+  TPLINK_HWID := 0x09410006
+  SUPPORTED_DEVICES += tl-wr941nd-v6
+endef
+TARGET_DEVICES += tplink_tl-wr941nd-v6
+
 define Device/tplink_tl-wr941n-v7-cn
   $(Device/tplink-4mlzma)
   ATH_SOC := qca9558