ath79: merge D-Link DAP-2695 with dtsi
authorSebastian Schaper <openwrt@sebastianschaper.net>
Mon, 30 Nov 2020 17:20:18 +0000 (18:20 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 20 Nov 2021 20:08:25 +0000 (21:08 +0100)
Further devices from the series have been added in the meantime,
introducing `qca955x_dlink_dap-2xxx.dtsi`.

Thus, merge support for DAP-2695 with the existing dtsi.

This implies factory images can now be flashed via the regular
OEM Web UI, as well as the bootloader recovery.

Signed-off-by: Sebastian Schaper <openwrt@sebastianschaper.net>
target/linux/ath79/dts/qca9558_dlink_dap-2695-a1.dts
target/linux/ath79/image/generic.mk

index 0317f1eabb71ee8fa109dedcfb98598278e204b5..f5a350b33fd0eae1cca335b361b44f5c04b3d4fd 100644 (file)
@@ -1,9 +1,6 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 
-#include "qca955x.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
+#include "qca955x_dlink_dap-2xxx.dtsi"
 
 / {
        compatible = "dlink,dap-2695-a1", "qca,qca9558";
        };
 };
 
-&spi {
-       status = "okay";
+&partitions {
+       partition@70000 {
+               label = "firmware";
+               reg = <0x070000 0xf00000>;
+               compatible = "wrg";
+       };
 
-       flash@0 {
-               #address-cells = <1>;
-               #size-cells = <1>;
-               compatible = "mx25l12805d";
-               reg = <0>;
-               spi-max-frequency = <50000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition@0 {
-                               label = "u-boot";
-                               reg = <0x000000 0x040000>;
-                               read-only;
-                       };
-
-                       partition@40000 {
-                               label = "bdcfg";
-                               reg = <0x040000 0x010000>;
-                               read-only;
-                       };
-
-                       partition@50000 {
-                               label = "rgdb";
-                               reg = <0x050000 0x010000>;
-                               read-only;
-                       };
-
-                       partition@60000 {
-                               label = "langpack";
-                               reg = <0x060000 0x010000>;
-                               read-only;
-                       };
-
-                       partition@70000 {
-                               compatible = "wrg";
-                               label = "firmware";
-                               reg = <0x070000 0xf00000>;
-                       };
-
-                       partition@f70000 {
-                               label = "captival";
-                               reg = <0xf70000 0x070000>;
-                               read-only;
-                       };
-
-                       partition@fe0000 {
-                               label = "certificate";
-                               reg = <0xfe0000 0x010000>;
-                               read-only;
-                       };
-
-                       art: partition@ff0000 {
-                               label = "art";
-                               reg = <0xff0000 0x010000>;
-                               read-only;
-                       };
-               };
+       partition@f70000 {
+               label = "captival";
+               reg = <0xf70000 0x070000>;
+               read-only;
+       };
+
+       partition@fe0000 {
+               label = "certificate";
+               reg = <0xfe0000 0x010000>;
+               read-only;
+       };
+
+       art: partition@ff0000 {
+               label = "art";
+               reg = <0xff0000 0x010000>;
+               read-only;
        };
 };
 
 &pcie0 {
        status = "okay";
 };
-
-&wmac {
-       status = "okay";
-
-       mtd-cal-data = <&art 0x1000>;
-};
index fb393ba082f6aac2b0afbbfb98469be2000c3121..39f616b01085a165426324e8200cdbd4541e3f4a 100644 (file)
@@ -845,20 +845,13 @@ endef
 TARGET_DEVICES += dlink_dap-2680-a1
 
 define Device/dlink_dap-2695-a1
+  $(Device/dlink_dap-2xxx)
   SOC := qca9558
-  DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DAP-2695
   DEVICE_VARIANT := A1
-  IMAGES := factory.img sysupgrade.bin
+  DEVICE_PACKAGES := ath10k-firmware-qca988x-ct kmod-ath10k-ct
   IMAGE_SIZE := 15360k
-  IMAGE/default := append-kernel | pad-offset 65536 160
-  IMAGE/factory.img := $$(IMAGE/default) | append-rootfs | wrgg-pad-rootfs | \
-       mkwrggimg | check-size
-  IMAGE/sysupgrade.bin := $$(IMAGE/default) | mkwrggimg | append-rootfs | \
-       wrgg-pad-rootfs | check-size | append-metadata
-  KERNEL := kernel-bin | append-dtb | relocate-kernel | lzma
-  KERNEL_INITRAMFS := $$(KERNEL) | mkwrggimg
   DAP_SIGNATURE := wapac02_dkbs_dap2695
   SUPPORTED_DEVICES += dap-2695-a1
 endef