ramips: improve support for STORYLiNK SAP-G3200U3
authorSungbo Eo <mans0n@gorani.run>
Sun, 10 Mar 2024 04:55:24 +0000 (13:55 +0900)
committerSungbo Eo <mans0n@gorani.run>
Sun, 10 Mar 2024 07:32:14 +0000 (16:32 +0900)
* Increase flash SPI frequency to 50MHz

  The maximum SPI frequency of MX25L6406EM2I is 86 MHz,
  but in this patch 50 MHz was chosen as a safe value.

* Update Ethernet MAC addresses

  Till now LAN/WAN MAC addresses were flipped
  compared to stock firmware.

* Fix Wi-Fi LEDs by adding mt76 led nodes

* Fix LAN port order

  LAN ports are in reverse order of switch ports.

* Fix the well-known "LZMA ERROR 1" error by using lzma-loader

* Set uImage name, which enables installation via stock web interface:

  1.  Upload **initramfs** image file to the web page.
  2.  Boot into OpenWrt and perform sysupgrade with sysupgrade image.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ramips/dts/mt7621_storylink_sap-g3200u3.dts
target/linux/ramips/image/mt7621.mk

index 7b89ee67274835081381dc4aeccf7ea3305c2128..3448db5f03d5a472521c6655046265766588a930 100644 (file)
@@ -43,7 +43,8 @@
        flash@0 {
                compatible = "jedec,spi-nor";
                reg = <0>;
-               spi-max-frequency = <10000000>;
+               spi-max-frequency = <50000000>;
+               m25p,fast-read;
 
                partitions {
                        compatible = "fixed-partitions";
                                                reg = <0x8000 0x200>;
                                        };
 
+                                       macaddr_factory_e000: macaddr@e000 {
+                                               reg = <0xe000 0x6>;
+                                       };
+
                                        macaddr_factory_e006: macaddr@e006 {
-                                               compatible = "mac-base";
                                                reg = <0xe006 0x6>;
-                                               #nvmem-cell-cells = <1>;
                                        };
                                };
                        };
 };
 
 &pcie0 {
-       mt76@0,0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
                reg = <0x0000 0 0 0 0>;
                nvmem-cells = <&eeprom_factory_8000>;
                nvmem-cell-names = "eeprom";
                ieee80211-freq-limit = <5000000 6000000>;
+
+               led {
+                       led-sources = <2>;
+                       led-active-low;
+               };
        };
 };
 
 &pcie1 {
-       mt76@0,0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
                reg = <0x0000 0 0 0 0>;
                nvmem-cells = <&eeprom_factory_0>;
                nvmem-cell-names = "eeprom";
                ieee80211-freq-limit = <2400000 2500000>;
+
+               led {
+                       led-sources = <2>;
+                       led-active-low;
+               };
        };
 };
 
 &gmac0 {
-       nvmem-cells = <&macaddr_factory_e000>;
+       nvmem-cells = <&macaddr_factory_e000>;
        nvmem-cell-names = "mac-address";
 };
 
        label = "wan";
        phy-handle = <&ethphy4>;
 
-       nvmem-cells = <&macaddr_factory_e006 1>;
+       nvmem-cells = <&macaddr_factory_e006>;
        nvmem-cell-names = "mac-address";
 };
 
        ports {
                port@0 {
                        status = "okay";
-                       label = "lan1";
+                       label = "lan4";
                };
 
                port@1 {
                        status = "okay";
-                       label = "lan2";
+                       label = "lan3";
                };
 
                port@2 {
                        status = "okay";
-                       label = "lan3";
+                       label = "lan2";
                };
 
                port@3 {
                        status = "okay";
-                       label = "lan4";
+                       label = "lan1";
                };
        };
 };
index 2ab687fd02aebc54982b8437119c328e1f75dc4a..a46ea39d59ff5af5cb0e11289917439129681204 100644 (file)
@@ -2190,7 +2190,9 @@ TARGET_DEVICES += snr_snr-cpe-me2-sfp
 
 define Device/storylink_sap-g3200u3
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 7872k
+  UIMAGE_NAME := SAP-G3200
   DEVICE_VENDOR := STORYLiNK
   DEVICE_MODEL := SAP-G3200U3
   DEVICE_PACKAGES := kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport \