comgt: Fix 3g.sh permissions
authorRosen Penev <rosenp@gmail.com>
Thu, 6 Dec 2018 04:43:04 +0000 (20:43 -0800)
committerJohn Crispin <john@phrozen.org>
Thu, 6 Dec 2018 07:42:39 +0000 (08:42 +0100)
3g.sh needs to be executable. 600 is not correct for that.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/network/utils/comgt/Makefile

index d4d673e783a521c4e4e0cf7874c74dcb19bc0997..58466f498c61c390b462f5ed927bf2f83c90cbee 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=31
+PKG_RELEASE:=32
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
@@ -82,7 +82,7 @@ define Package/comgt/install
        $(INSTALL_DIR) $(1)/etc/hotplug.d/tty
        $(INSTALL_CONF) ./files/3g.usb $(1)/etc/hotplug.d/tty/30-3g
        $(INSTALL_DIR) $(1)/lib/netifd/proto
-       $(INSTALL_CONF) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
+       $(INSTALL_BIN) ./files/3g.sh $(1)/lib/netifd/proto/3g.sh
 endef
 
 define Package/comgt-directip/install