ath25: fix ELF image generation
authorLech Perczak <lech.perczak@gmail.com>
Tue, 9 Aug 2022 23:06:24 +0000 (01:06 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 14 Aug 2022 19:06:53 +0000 (21:06 +0200)
Commit 21f460a5dbef ("ath25: fix duplicate LZMA compression"), when
attempting to restore ELF artifact generation, copiedover the raw
kernel image twice. Because of that, the .elf artifact was actually a
duplicate of raw image.

Fix that by copying over .elf suffixed kernel image instead.

Fixes: 21f460a5dbef ("ath25: fix duplicate LZMA compression")
Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
(cherry picked from commit 611291383a826827f240eddebca1949c2e1e7115)

target/linux/ath25/image/Makefile

index 2b22d54105a3d2d47bbe9f94f5f54bf940815137..d6cd53d2619e342b3f04b21369209277a518a532 100644 (file)
@@ -43,7 +43,7 @@ endef
 define Build/copy-kernel
        rm -f $@ $@.elf
        cp $< $@
-       cp $< $@.elf
+       cp $<.elf $@.elf
 endef
 
 define Build/elf-kernel