ar71xx: add Abicom SC1750 support
authorConor O'Gorman <i@conorogorman.net>
Sun, 15 Jan 2017 22:01:05 +0000 (22:01 +0000)
committerJohn Crispin <john@phrozen.org>
Thu, 19 Jan 2017 23:40:40 +0000 (00:40 +0100)
Support Abicom International Scorpion SC1750 Board

QCA9550 700MHz Extended Temperature Range
256MB DDR2
256MB Nand Flash
16MB Nor Flash
1x SFP, 1x PCIe
2x 10/100/1000 Ethernet
135x100 mm
802.11ng/g/b
802.11ac/an/a

Signed-off-by: Conor O'Gorman <i@conorogorman.net>
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.4
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-sc1750.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/generic.mk

index 58f1dd611668a8b860bf656a290838647cdf96d9..fb0dda3ddc82f24cae3097d11e73220074b0ad5b 100755 (executable)
@@ -440,6 +440,7 @@ re450)
        ucidef_set_led_wlan "wlan2g" "WLAN 2.4 GHz" "$board:blue:wlan2g" "phy1tpt"
        ucidef_set_led_wlan "wlan5g" "WLAN 5 GHz" "$board:blue:wlan5g" "phy0tpt"
        ;;
+sc1750|\
 sc450)
        ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
        ;;
index 83a0e501978dc9d0f5528f02d1c0bfe01ada5078..4bbb93a60fa6e06cb7b9440c6c0bd82fd9ea0d55 100644 (file)
@@ -44,6 +44,7 @@ get_status_led() {
        mr12|\
        mr16|\
        nbg6616|\
+       sc1750|\
        sc450|\
        tl-wpa8630)
                status_led="$board:green:power"
index 6c3396b6a5e5316f258231b924eb487bb51d6bb6..eb8b671b976d381cee10197a625ce8afd3b082bb 100755 (executable)
@@ -884,6 +884,9 @@ ar71xx_board_detect() {
        *RW2458N)
                name="rw2458n"
                ;;
+       *SC1750)
+               name="sc1750"
+               ;;
        *SC300M)
                name="sc300m"
                ;;
index f50dd80ef3298739d7197985229423fa0a0938af..02eb960db3ea4ab51a3a5f849b4290aadfae5224 100755 (executable)
@@ -254,6 +254,7 @@ platform_check_image() {
        rocket-m-xw|\
        rocket-m|\
        rw2458n|\
+       sc1750|\
        sc300m|\
        sc450|\
        sr3200|\
index b6345d6705d554a4de69d4b14fc63d1be43b7914..427e8bd2be8c7823bc42ebc5b66aa8c7d90e0a48 100644 (file)
@@ -148,6 +148,7 @@ CONFIG_ATH79_MACH_R6100=y
 # CONFIG_ATH79_MACH_RBSXTLITE is not set
 CONFIG_ATH79_MACH_RE450=y
 CONFIG_ATH79_MACH_RW2458N=y
+CONFIG_ATH79_MACH_SC1750=y
 CONFIG_ATH79_MACH_SC300M=y
 CONFIG_ATH79_MACH_SC450=y
 CONFIG_ATH79_MACH_SMART_300=y
index 28555060d1dc214c4c3868dad4be01ae9ed73209..3c10be9e2405099b4de12eb7d29c16aa07926fee 100644 (file)
@@ -42,6 +42,17 @@ config ATH79_MACH_TUBE2H
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_SC1750
+       bool "Abicom SC1750 board support"
+       select SOC_QCA955X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_SC300M
        bool "Abicom SC300M board support"
        select SOC_QCA955X
index 9d6b6b90bf6054f6ab94046ab2f8ad906e913fd7..8ce07a49b5cbacf2d4a43fae398d42a9d75c9dea 100644 (file)
@@ -152,6 +152,7 @@ obj-$(CONFIG_ATH79_MACH_RB95X)                      += mach-rb95x.o
 obj-$(CONFIG_ATH79_MACH_RBSXTLITE)             += mach-rbsxtlite.o
 obj-$(CONFIG_ATH79_MACH_RE450)                 += mach-re450.o
 obj-$(CONFIG_ATH79_MACH_RW2458N)               += mach-rw2458n.o
+obj-$(CONFIG_ATH79_MACH_SC1750)                        += mach-sc1750.o
 obj-$(CONFIG_ATH79_MACH_SC300M)                        += mach-sc300m.o
 obj-$(CONFIG_ATH79_MACH_SC450)                 += mach-sc450.o
 obj-$(CONFIG_ATH79_MACH_SMART_300)             += mach-smart-300.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-sc1750.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-sc1750.c
new file mode 100644 (file)
index 0000000..653d642
--- /dev/null
@@ -0,0 +1,145 @@
+/*
+ * Abicom International Scorpion SC1750 support.
+ *
+ * Copyright (c) 2012 Qualcomm Atheros
+ * Copyright (c) 2012-2013 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (c) 2017 Conor O'Gorman <i@conorogorman.net>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/platform_device.h>
+#include <linux/platform_data/phy-at803x.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-nfc.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define SC1750_GPIO_LED_POWER          11
+#define SC1750_GPIO_LED_ERR1           12
+#define SC1750_GPIO_LED_WLAN           13
+#define SC1750_GPIO_LED_ERR2           14
+#define SC1750_GPIO_LED_OK3            15
+#define SC1750_GPIO_LED_ERR3           16
+#define SC1750_GPIO_BTN_RESET          4
+
+#define SC1750_KEYS_POLL_INTERVAL      20      /* msecs */
+#define SC1750_KEYS_DEBOUNCE_INTERVAL  (3 * SC1750_KEYS_POLL_INTERVAL)
+
+#define SC1750_MAC0_OFFSET             0
+#define SC1750_MAC1_OFFSET             6
+#define SC1750_WMAC_CALDATA_OFFSET     0x1000
+#define SC1750_PCIE_CALDATA_OFFSET     0x5000
+
+static struct gpio_led sc1750_leds_gpio[] __initdata = {
+       {
+               .name           = "sc1750:green:power",
+               .gpio           = SC1750_GPIO_LED_POWER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "sc1750:red:power",
+               .gpio           = SC1750_GPIO_LED_ERR1,
+               .active_low     = 1,
+       },
+       {
+               .name           = "sc1750:green:wlan",
+               .gpio           = SC1750_GPIO_LED_WLAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "sc1750:red:wlan",
+               .gpio           = SC1750_GPIO_LED_ERR2,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button sc1750_gpio_keys[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = SC1750_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = SC1750_GPIO_BTN_RESET,
+               .active_low     = 0,
+       }
+};
+
+static struct at803x_platform_data at803x_data = {
+       .disable_smarteee = 1,
+       .enable_rgmii_rx_delay = 0,
+       .enable_rgmii_tx_delay = 0,
+};
+
+static struct mdio_board_info sc1750_mdio0_info[] = {
+       {
+               .bus_id = "ag71xx-mdio.0",
+               .phy_addr = 1,
+               .platform_data = &at803x_data,
+       },
+};
+
+static void __init sc1750_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(sc1750_leds_gpio),
+                                sc1750_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, SC1750_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(sc1750_gpio_keys),
+                                       sc1750_gpio_keys);
+
+       ath79_register_usb();
+       ath79_register_nfc();
+
+       ath79_register_wmac(art + SC1750_WMAC_CALDATA_OFFSET, NULL);
+
+       ath79_register_mdio(0, 0);
+       mdiobus_register_board_info(sc1750_mdio0_info,
+                                   ARRAY_SIZE(sc1750_mdio0_info));
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, art + SC1750_MAC0_OFFSET, 0);
+
+       ath79_eth0_pll_data.pll_1000 = 0xa6000101;
+       ath79_eth0_pll_data.pll_100 = 0xa4000101;
+       /* GMAC0 is connected to the RMGII interface */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ath79_eth0_data.phy_mask = 0xF;
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+
+       ath79_register_eth(0);
+
+       /* GMAC1 is connected to the SGMII interface */
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+
+       ath79_register_eth(1);
+
+       ath79_register_pci();
+}
+
+MIPS_MACHINE(ATH79_MACH_SC1750, "SC1750", "Abicom SC1750", sc1750_setup);
index 03fdc5e51d9071e3a34b66aaed471dc2ae83e50a..b7946e55e42a062ea453c7d1383de81649d61e1b 100644 (file)
@@ -169,6 +169,7 @@ enum ath79_mach_type {
        ATH79_MACH_RB_SXTLITE5ND,               /* Mikrotik RouterBOARD SXT Lite 5nD */
        ATH79_MACH_RE450,                       /* TP-LINK RE450 */
        ATH79_MACH_RW2458N,                     /* Redwave RW2458N */
+       ATH79_MACH_SC1750,                      /* Abicom SC1750 */
        ATH79_MACH_SC300M,                      /* Abicom SC300M */
        ATH79_MACH_SC450,                       /* Abicom SC450 */
        ATH79_MACH_SMART_300,                   /* NC-LINK SMART-300 */
index 02b90b0aa614c41cf1db9d28e07655f4a868a615..0214c530eecae144c06af2eb25f25cc38119b555 100644 (file)
@@ -464,6 +464,16 @@ define Device/onion-omega
 endef
 TARGET_DEVICES += onion-omega
 
+define Device/sc1750
+  DEVICE_TITLE := Abicom SC1750
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+  BOARDNAME = SC1750
+  IMAGE_SIZE = 15744k
+  CONSOLE = ttyS0,115200
+  MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),15744k(firmware),128k(APConfig),128k(kplog),64k(ART)
+endef
+TARGET_DEVICES += sc1750
+
 define Device/sc300m
   DEVICE_TITLE := Abicom SC300M
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport