tools: patch: Add missing CVE-2018-6951 fix
authorRosen Penev <rosenp@gmail.com>
Mon, 15 Oct 2018 17:17:29 +0000 (10:17 -0700)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:22:06 +0000 (17:22 +0100)
uscan reports a new CVE now that PKG_CPE_ID was added.

Reordered patches by date.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
[re-title commit & refresh patches]
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
(backported from a6bd9d0cb652686453604b762e80a35d023908c4)

tools/patch/Makefile
tools/patch/patches/010-CVE-2018-1000156.patch [deleted file]
tools/patch/patches/010-CVE-2018-6951.patch [new file with mode: 0644]
tools/patch/patches/020-CVE-2018-1000156.patch [new file with mode: 0644]
tools/patch/patches/020-CVE-2018-6952.patch [deleted file]
tools/patch/patches/030-CVE-2018-6952.patch [new file with mode: 0644]

index 0f4d7f0326c156277373f0ee424f7629783abd08..7323b5b2ab7febdcf0023191d1c6992135e78dc6 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=patch
 PKG_VERSION:=2.7.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_CPE_ID:=cpe:/a:gnu:patch
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
diff --git a/tools/patch/patches/010-CVE-2018-1000156.patch b/tools/patch/patches/010-CVE-2018-1000156.patch
deleted file mode 100644 (file)
index 7114f82..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-From ee2904728eb4364a36d62d66f723d0b68749e5df Mon Sep 17 00:00:00 2001
-From: Andreas Gruenbacher <agruen@gnu.org>
-Date: Fri, 6 Apr 2018 12:14:49 +0200
-Subject: [PATCH] Fix arbitrary command execution in ed-style patches
- (CVE-2018-1000156)
-
-* src/pch.c (do_ed_script): Write ed script to a temporary file instead
-of piping it to ed: this will cause ed to abort on invalid commands
-instead of rejecting them and carrying on.
-* tests/ed-style: New test case.
-* tests/Makefile.am (TESTS): Add test case.
----
- src/pch.c         | 89 +++++++++++++++++++++++++++++++++++------------
- tests/Makefile.am |  1 +
- tests/ed-style    | 41 ++++++++++++++++++++++
- 3 files changed, 108 insertions(+), 23 deletions(-)
- create mode 100644 tests/ed-style
-
---- a/src/pch.c
-+++ b/src/pch.c
-@@ -33,6 +33,7 @@
- # include <io.h>
- #endif
- #include <safe.h>
-+#include <sys/wait.h>
- #define INITHUNKMAX 125                       /* initial dynamic allocation size */
-@@ -2388,22 +2389,28 @@ do_ed_script (char const *inname, char c
-     static char const editor_program[] = EDITOR_PROGRAM;
-     file_offset beginning_of_this_line;
--    FILE *pipefp = 0;
-     size_t chars_read;
-+    FILE *tmpfp = 0;
-+    char const *tmpname;
-+    int tmpfd;
-+    pid_t pid;
-+
-+    if (! dry_run && ! skip_rest_of_patch)
-+      {
-+      /* Write ed script to a temporary file.  This causes ed to abort on
-+         invalid commands such as when line numbers or ranges exceed the
-+         number of available lines.  When ed reads from a pipe, it rejects
-+         invalid commands and treats the next line as a new command, which
-+         can lead to arbitrary command execution.  */
-+
-+      tmpfd = make_tempfile (&tmpname, 'e', NULL, O_RDWR | O_BINARY, 0);
-+      if (tmpfd == -1)
-+        pfatal ("Can't create temporary file %s", quotearg (tmpname));
-+      tmpfp = fdopen (tmpfd, "w+b");
-+      if (! tmpfp)
-+        pfatal ("Can't open stream for file %s", quotearg (tmpname));
-+      }
--    if (! dry_run && ! skip_rest_of_patch) {
--      int exclusive = *outname_needs_removal ? 0 : O_EXCL;
--      assert (! inerrno);
--      *outname_needs_removal = true;
--      copy_file (inname, outname, 0, exclusive, instat.st_mode, true);
--      sprintf (buf, "%s %s%s", editor_program,
--               verbosity == VERBOSE ? "" : "- ",
--               outname);
--      fflush (stdout);
--      pipefp = popen(buf, binary_transput ? "wb" : "w");
--      if (!pipefp)
--        pfatal ("Can't open pipe to %s", quotearg (buf));
--    }
-     for (;;) {
-       char ed_command_letter;
-       beginning_of_this_line = file_tell (pfp);
-@@ -2414,14 +2421,14 @@ do_ed_script (char const *inname, char c
-       }
-       ed_command_letter = get_ed_command_letter (buf);
-       if (ed_command_letter) {
--          if (pipefp)
--              if (! fwrite (buf, sizeof *buf, chars_read, pipefp))
-+          if (tmpfp)
-+              if (! fwrite (buf, sizeof *buf, chars_read, tmpfp))
-                   write_fatal ();
-           if (ed_command_letter != 'd' && ed_command_letter != 's') {
-               p_pass_comments_through = true;
-               while ((chars_read = get_line ()) != 0) {
--                  if (pipefp)
--                      if (! fwrite (buf, sizeof *buf, chars_read, pipefp))
-+                  if (tmpfp)
-+                      if (! fwrite (buf, sizeof *buf, chars_read, tmpfp))
-                           write_fatal ();
-                   if (chars_read == 2  &&  strEQ (buf, ".\n"))
-                       break;
-@@ -2434,13 +2441,49 @@ do_ed_script (char const *inname, char c
-           break;
-       }
-     }
--    if (!pipefp)
-+    if (!tmpfp)
-       return;
--    if (fwrite ("w\nq\n", sizeof (char), (size_t) 4, pipefp) == 0
--      || fflush (pipefp) != 0)
-+    if (fwrite ("w\nq\n", sizeof (char), (size_t) 4, tmpfp) == 0
-+      || fflush (tmpfp) != 0)
-       write_fatal ();
--    if (pclose (pipefp) != 0)
--      fatal ("%s FAILED", editor_program);
-+
-+    if (lseek (tmpfd, 0, SEEK_SET) == -1)
-+      pfatal ("Can't rewind to the beginning of file %s", quotearg (tmpname));
-+
-+    if (! dry_run && ! skip_rest_of_patch) {
-+      int exclusive = *outname_needs_removal ? 0 : O_EXCL;
-+      *outname_needs_removal = true;
-+      if (inerrno != ENOENT)
-+        {
-+          *outname_needs_removal = true;
-+          copy_file (inname, outname, 0, exclusive, instat.st_mode, true);
-+        }
-+      sprintf (buf, "%s %s%s", editor_program,
-+               verbosity == VERBOSE ? "" : "- ",
-+               outname);
-+      fflush (stdout);
-+
-+      pid = fork();
-+      if (pid == -1)
-+        pfatal ("Can't fork");
-+      else if (pid == 0)
-+        {
-+          dup2 (tmpfd, 0);
-+          execl ("/bin/sh", "sh", "-c", buf, (char *) 0);
-+          _exit (2);
-+        }
-+      else
-+        {
-+          int wstatus;
-+          if (waitpid (pid, &wstatus, 0) == -1
-+              || ! WIFEXITED (wstatus)
-+              || WEXITSTATUS (wstatus) != 0)
-+            fatal ("%s FAILED", editor_program);
-+        }
-+    }
-+
-+    fclose (tmpfp);
-+    safe_unlink (tmpname);
-     if (ofp)
-       {
diff --git a/tools/patch/patches/010-CVE-2018-6951.patch b/tools/patch/patches/010-CVE-2018-6951.patch
new file mode 100644 (file)
index 0000000..10dc568
--- /dev/null
@@ -0,0 +1,24 @@
+From 1f7853c05f9949d81da9be7a02b90cc64284d1f8 Mon Sep 17 00:00:00 2001
+From: Andreas Gruenbacher <agruen@gnu.org>
+Date: Mon, 12 Feb 2018 16:48:24 +0100
+Subject: [PATCH] Fix segfault with mangled rename patch
+
+http://savannah.gnu.org/bugs/?53132
+* src/pch.c (intuit_diff_type): Ensure that two filenames are specified
+for renames and copies (fix the existing check).
+---
+ src/pch.c | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+--- a/src/pch.c
++++ b/src/pch.c
+@@ -974,7 +974,8 @@ intuit_diff_type (bool need_header, mode
+     if ((pch_rename () || pch_copy ())
+       && ! inname
+       && ! ((i == OLD || i == NEW) &&
+-            p_name[! reverse] &&
++            p_name[reverse] && p_name[! reverse] &&
++            name_is_valid (p_name[reverse]) &&
+             name_is_valid (p_name[! reverse])))
+       {
+       say ("Cannot %s file without two valid file names\n", pch_rename () ? "rename" : "copy");
diff --git a/tools/patch/patches/020-CVE-2018-1000156.patch b/tools/patch/patches/020-CVE-2018-1000156.patch
new file mode 100644 (file)
index 0000000..99dfe54
--- /dev/null
@@ -0,0 +1,142 @@
+From b3a0ca3deed00334f9feece43f76776b6a168e47 Mon Sep 17 00:00:00 2001
+From: Andreas Gruenbacher <agruen@gnu.org>
+Date: Fri, 6 Apr 2018 12:14:49 +0200
+Subject: [PATCH] Fix arbitrary command execution in ed-style patches
+ (CVE-2018-1000156)
+
+* src/pch.c (do_ed_script): Write ed script to a temporary file instead
+of piping it to ed: this will cause ed to abort on invalid commands
+instead of rejecting them and carrying on.
+* tests/ed-style: New test case.
+* tests/Makefile.am (TESTS): Add test case.
+---
+ src/pch.c | 89 +++++++++++++++++++++++++++++++++++++++++--------------
+ 1 file changed, 66 insertions(+), 23 deletions(-)
+
+--- a/src/pch.c
++++ b/src/pch.c
+@@ -33,6 +33,7 @@
+ # include <io.h>
+ #endif
+ #include <safe.h>
++#include <sys/wait.h>
+ #define INITHUNKMAX 125                       /* initial dynamic allocation size */
+@@ -2389,22 +2390,28 @@ do_ed_script (char const *inname, char c
+     static char const editor_program[] = EDITOR_PROGRAM;
+     file_offset beginning_of_this_line;
+-    FILE *pipefp = 0;
+     size_t chars_read;
++    FILE *tmpfp = 0;
++    char const *tmpname;
++    int tmpfd;
++    pid_t pid;
++
++    if (! dry_run && ! skip_rest_of_patch)
++      {
++      /* Write ed script to a temporary file.  This causes ed to abort on
++         invalid commands such as when line numbers or ranges exceed the
++         number of available lines.  When ed reads from a pipe, it rejects
++         invalid commands and treats the next line as a new command, which
++         can lead to arbitrary command execution.  */
++
++      tmpfd = make_tempfile (&tmpname, 'e', NULL, O_RDWR | O_BINARY, 0);
++      if (tmpfd == -1)
++        pfatal ("Can't create temporary file %s", quotearg (tmpname));
++      tmpfp = fdopen (tmpfd, "w+b");
++      if (! tmpfp)
++        pfatal ("Can't open stream for file %s", quotearg (tmpname));
++      }
+-    if (! dry_run && ! skip_rest_of_patch) {
+-      int exclusive = *outname_needs_removal ? 0 : O_EXCL;
+-      assert (! inerrno);
+-      *outname_needs_removal = true;
+-      copy_file (inname, outname, 0, exclusive, instat.st_mode, true);
+-      sprintf (buf, "%s %s%s", editor_program,
+-               verbosity == VERBOSE ? "" : "- ",
+-               outname);
+-      fflush (stdout);
+-      pipefp = popen(buf, binary_transput ? "wb" : "w");
+-      if (!pipefp)
+-        pfatal ("Can't open pipe to %s", quotearg (buf));
+-    }
+     for (;;) {
+       char ed_command_letter;
+       beginning_of_this_line = file_tell (pfp);
+@@ -2415,14 +2422,14 @@ do_ed_script (char const *inname, char c
+       }
+       ed_command_letter = get_ed_command_letter (buf);
+       if (ed_command_letter) {
+-          if (pipefp)
+-              if (! fwrite (buf, sizeof *buf, chars_read, pipefp))
++          if (tmpfp)
++              if (! fwrite (buf, sizeof *buf, chars_read, tmpfp))
+                   write_fatal ();
+           if (ed_command_letter != 'd' && ed_command_letter != 's') {
+               p_pass_comments_through = true;
+               while ((chars_read = get_line ()) != 0) {
+-                  if (pipefp)
+-                      if (! fwrite (buf, sizeof *buf, chars_read, pipefp))
++                  if (tmpfp)
++                      if (! fwrite (buf, sizeof *buf, chars_read, tmpfp))
+                           write_fatal ();
+                   if (chars_read == 2  &&  strEQ (buf, ".\n"))
+                       break;
+@@ -2435,13 +2442,49 @@ do_ed_script (char const *inname, char c
+           break;
+       }
+     }
+-    if (!pipefp)
++    if (!tmpfp)
+       return;
+-    if (fwrite ("w\nq\n", sizeof (char), (size_t) 4, pipefp) == 0
+-      || fflush (pipefp) != 0)
++    if (fwrite ("w\nq\n", sizeof (char), (size_t) 4, tmpfp) == 0
++      || fflush (tmpfp) != 0)
+       write_fatal ();
+-    if (pclose (pipefp) != 0)
+-      fatal ("%s FAILED", editor_program);
++
++    if (lseek (tmpfd, 0, SEEK_SET) == -1)
++      pfatal ("Can't rewind to the beginning of file %s", quotearg (tmpname));
++
++    if (! dry_run && ! skip_rest_of_patch) {
++      int exclusive = *outname_needs_removal ? 0 : O_EXCL;
++      *outname_needs_removal = true;
++      if (inerrno != ENOENT)
++        {
++          *outname_needs_removal = true;
++          copy_file (inname, outname, 0, exclusive, instat.st_mode, true);
++        }
++      sprintf (buf, "%s %s%s", editor_program,
++               verbosity == VERBOSE ? "" : "- ",
++               outname);
++      fflush (stdout);
++
++      pid = fork();
++      if (pid == -1)
++        pfatal ("Can't fork");
++      else if (pid == 0)
++        {
++          dup2 (tmpfd, 0);
++          execl ("/bin/sh", "sh", "-c", buf, (char *) 0);
++          _exit (2);
++        }
++      else
++        {
++          int wstatus;
++          if (waitpid (pid, &wstatus, 0) == -1
++              || ! WIFEXITED (wstatus)
++              || WEXITSTATUS (wstatus) != 0)
++            fatal ("%s FAILED", editor_program);
++        }
++    }
++
++    fclose (tmpfp);
++    safe_unlink (tmpname);
+     if (ofp)
+       {
diff --git a/tools/patch/patches/020-CVE-2018-6952.patch b/tools/patch/patches/020-CVE-2018-6952.patch
deleted file mode 100644 (file)
index e72a8cb..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-From daa51e492049d9fe3ac049165ec19641bf19cd7f Mon Sep 17 00:00:00 2001
-From: Andreas Gruenbacher <agruen@gnu.org>
-Date: Fri, 17 Aug 2018 13:35:40 +0200
-Subject: [PATCH] Fix swapping fake lines in pch_swap
-
-* src/pch.c (pch_swap): Fix swapping p_bfake and p_efake when there is a
-blank line in the middle of a context-diff hunk: that empty line stays
-in the middle of the hunk and isn't swapped.
-
-Fixes: https://savannah.gnu.org/bugs/index.php?53133
----
- src/pch.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/src/pch.c
-+++ b/src/pch.c
-@@ -2114,7 +2114,7 @@ pch_swap (void)
-     }
-     if (p_efake >= 0) {                       /* fix non-freeable ptr range */
-       if (p_efake <= i)
--          n = p_end - i + 1;
-+          n = p_end - p_ptrn_lines;
-       else
-           n = -i;
-       p_efake += n;
diff --git a/tools/patch/patches/030-CVE-2018-6952.patch b/tools/patch/patches/030-CVE-2018-6952.patch
new file mode 100644 (file)
index 0000000..36b58c7
--- /dev/null
@@ -0,0 +1,25 @@
+From df40f2ea17254de269a3624319a12a93a4e395ff Mon Sep 17 00:00:00 2001
+From: Andreas Gruenbacher <agruen@gnu.org>
+Date: Fri, 17 Aug 2018 13:35:40 +0200
+Subject: [PATCH] Fix swapping fake lines in pch_swap
+
+* src/pch.c (pch_swap): Fix swapping p_bfake and p_efake when there is a
+blank line in the middle of a context-diff hunk: that empty line stays
+in the middle of the hunk and isn't swapped.
+
+Fixes: https://savannah.gnu.org/bugs/index.php?53133
+---
+ src/pch.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/src/pch.c
++++ b/src/pch.c
+@@ -2115,7 +2115,7 @@ pch_swap (void)
+     }
+     if (p_efake >= 0) {                       /* fix non-freeable ptr range */
+       if (p_efake <= i)
+-          n = p_end - i + 1;
++          n = p_end - p_ptrn_lines;
+       else
+           n = -i;
+       p_efake += n;