ath25: disable image generation for ubnt2 and ubnt5 devices
authorPetr Štetiar <ynezz@true.cz>
Sat, 20 Jul 2019 06:57:23 +0000 (08:57 +0200)
committerPetr Štetiar <ynezz@true.cz>
Sat, 20 Jul 2019 06:57:23 +0000 (08:57 +0200)
Image generations is currently failing on builbots due to the following
errors:

 mkfwimage -B XS2 -v XS2 [...] ath25-ubnt2-squashfs-sysupgrade.bin
 ERROR: Failed creating firmware layout description - error code: -2

 mkfwimage -B XS5 -v XS5 [...] ath25-ubnt5-squashfs-sysupgrade.bin
 ERROR: Failed creating firmware layout description - error code: -2

That cryptic -2 error simply means, that kernel+rootfs doesn't fit into
the firmware partition.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ath25/image/Makefile

index 5a20bdb64454459cdc90119b979428a5e6427d15..ee5e74e692f2772ac19dad450f293ab5cc991f59 100644 (file)
@@ -82,13 +82,13 @@ define Device/ubnt2
   DEVICE_TITLE := Ubiquiti XS2
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkfwimage XS2 -v XS2.ar2316
 endef
-TARGET_DEVICES += ubnt2
+#TARGET_DEVICES += ubnt2
 
 define Device/ubnt5
   DEVICE_TITLE := Ubiquiti XS5
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | pad-to 128k | mkfwimage XS5 -v XS5.ar2313
 endef
-TARGET_DEVICES += ubnt5
+#TARGET_DEVICES += ubnt5
 
 define Device/np25g
   DEVICE_TITLE := np25g