Lantiq TAPI driver also build for other platforms
authorJohn Crispin <john@openwrt.org>
Wed, 6 Jul 2011 13:41:16 +0000 (13:41 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 6 Jul 2011 13:41:16 +0000 (13:41 +0000)
thanks Matthias Buecher

SVN-Revision: 27494

package/ltq-tapi/Makefile

index ecaac2eeb457044d291329652b2ba6c71b66d520..656ae15050038ac758f77bc97c38687c6e556120 100644 (file)
@@ -22,7 +22,7 @@ define KernelPackage/ltq-tapi
   SUBMENU:=Voice over IP
   TITLE:=Lantiq TAPI subsystem
   URL:=http://www.lantiq.com/
-  DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq
+  DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq_xway
   FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
   AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
   MAINTAINER:=John Crispin <blogic@openwrt.org>
@@ -60,10 +60,12 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-define Build/InstallDev
+ifdef CONFIG_TARGET_lantiq
+  define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/drv_tapi
        $(CP) --dereference $(PKG_BUILD_DIR)/include/* $(1)/usr/include/drv_tapi
        (cd $(1)/usr/include/drv_tapi && ln -s . include && ln -s ../ifxos/ifx_types.h .)
-endef
+  endef
+endif
 
 $(eval $(call KernelPackage,ltq-tapi))