kernel: can: fix MCP251x CAN controller module autoload
authorTim Harvey <tharvey@gateworks.com>
Sat, 18 Feb 2023 00:53:18 +0000 (16:53 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 18 Feb 2023 18:54:08 +0000 (19:54 +0100)
Fix autoload module name for can-mcp251x kmod.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
package/kernel/linux/modules/can.mk

index 9cdebb9091a67db2ff7036cdf9832f0f9a9744ef..4ff85d1c01379db7e7ffbadf75509349ea88dfd3 100644 (file)
@@ -152,7 +152,7 @@ define KernelPackage/can-mcp251x
        CONFIG_SPI=y \
        CONFIG_CAN_MCP251X
   FILES:=$(LINUX_DIR)/drivers/net/can/spi/mcp251x.ko
-  AUTOLOAD:=$(call AutoProbe,can-mcp251x)
+  AUTOLOAD:=$(call AutoProbe,mcp251x)
   $(call AddDepends/can)
 endef